8290 questions

9757 answers

15535 comments

13844 members

+1 vote
401 views 24 comments
by
Hi, just received a shiny new RUTX09 and seems to be a robust piece of kit.

Have a stable internet connection with 4G

HAve tried to set up Wireguard to connect to Torguard VPN.

I have successfully performed a handshake and can ping and traceroute IP and FQDN. (after adding DNS servers to LAN settings) direct from CLI

I cannot use my devices on the internet, there is no ping or traceroute and the devices state there is no internet connection. I have disabled the firewall and it made no difference.

Am I missing a Port Forwarding command?

1 Answer

0 votes
by

Hello,

Thank you for contacting .

May i know if the device is on the latest firmware ?

Are you sure you are using the correct DNS ?

Are you sure you used correct configurations for adding DNS to LAN settings through CLI ? Can you share ?

 Might be you configured something wrong.

You can also add it through webui. Have you tried from webui ?

And have you checked on the device itself if it has internet connection ?

You can check in System>Administration>Diagnostics 

Thank you. 

Regards,

Ahmed

by

The limitation must come from the AllowedIPs at the other end of the tunnel it is probably restricted to 10.13.128.117.

Can you do another test:

start the tunnel

execute: iptables -t nat -I POSTROUTING -o Torguard -j SNAT --to 10.13.128.117

and retry the ping from another device. Check the counters with ifconfig Torguard.

by
Nope, now I have no vpn when pinging from the router
by
SOLVED:

Covered networks had not selected the VPN Wireguard connection "Torguard" in Firewall --> General --> Wiregaurd -> LAN settings
by
Glad you found it.
by

Nope more issues, For this with similar another post is https://community.teltonika-networks.com/33512/wireguard-and-dns-servers