FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
727 views 4 comments
by anonymous

How can we change this to speed:10baseT half-duplex autoneg off,

# swconfig dev switch0 port 2 get link
port:2 link:up speed:100baseT full-duplex auto

This needs to be manually set to get legacy IoT-device to function correctly.

1 Answer

0 votes
by anonymous

Hello, 

You should be able to change only change WAN interface settings, but not LAN.

For the WAN interface, use the following command:

ethtool -s eth1 speed 100 duplex half autoneg off


Regards,
Mellow

by anonymous
We would need to change switchport settings like in this post,

https://forum.openwrt.org/t/how-to-set-lan-port-speed-using-swconfig/37563
by anonymous
Hello,

As for our Teltonika devices, you can only change the link state of the WAN port. For the reference you shared, the device mentioned there is using different hardware.

I hope this clarifies everything

Regards,
Mellow
by anonymous

Could you confirm that RUTX09 has also WAN mapped to CPU as eth1?

~# swconfig dev switch0 show | grep link:
        link: port:0 link:up speed:1000baseT full-duplex txflow rxflow # CPU?
        link: port:1 link:down # UNKNOWN?
        link: port:2 link:up speed:100baseT full-duplex auto # LAN1
        link: port:3 link:up speed:100baseT full-duplex auto # LAN2
        link: port:4 link:down # LAN3
        link: port:5 link:down # WAN?
by anonymous

Hello,

Here are the details for the switchports of our device. 

 link: port:2 link: - LAN1

 link: port:3 link: - LAN2

 link: port:4 link: - LAN3

 link: port:5 link: - WAN1

link: port:0 - CPU

Hope it helps, 

Regards,

Mellow