FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
2,782 views 5 comments
by
Hi

I have tried to update the units firmware but it is stuck at "Downloading...93%.  Downloading over 4G with 50Mb connection.

Spinning wheel, what should I do next. Can I ignore the "DO NOT POWER OFF THE DEVICE" warning and start again?

BR

Justin K
by
Same problem. Stuck with update.

Even after 1 hr stuck at 9x %

Same old firmware never rebooted.

Buying something else is my solution.

1 Answer

0 votes
by anonymous

Hello,

It might be possible that your browser stopped displaying the progress even though router already successfully upgraded its firmware version.

To start with, try to reach router again via "192.168.1.1" (or other IP if you have changed router's LAN IP and upgraded firmware keeping previous settings).

If router is not reachable, simply reboot the device and let us know if device is reachable after reboot.

by anonymous
Same issue here. Stuck on 93% when upgrading via "Upgrade from Server" option from RUT9XX_R_00.03.832 to  RUT9XX_R_00.04.75_WEBUI.bin.

I opened a new tab and checked the status and version but it has not changed. I am doing this via teamviewer remotely so am a bit concerned about trying to reboot the device mid process.

Thanks
by anonymous

I tried uploading RUT9XX_R_00.06.00.2 and upgrading from that file, but I lost comms at 53%.

I checked the "keep settings" option so it shouldn't have lost the IP address.

by anonymous

Hello,

Please take note that during firmware update process computer completely looses connection to the router. The process percentages which you see in the browser while device is being updated is purely shown by the browser itself (router's firmware update menu window, which browser loads before the update process, has information what % value to shown after certain amount of time has passed after the start of the update process).

If your browser stops "counting up" the percentage values, this is related with the browser itself, not the router. You can close this page at any time after starting the update process, since the update is happening inside the router and web browser's window is not interacting/interfering with it in any way.

Simply do not power device off while device is being updated (LAN LEDs are flashing "back and forth").

After initiating firmware update, wait few minutes and then simply try to access router's "LAN IP (default 192.168.1.1)" from same or separate web browsers window. Router should be reachable.

by

The firmware doesn't seem to update via that way - it still has got RUT9XX_R_00.03.832

I tried this 3 times already now. It always gets stuck on 93% and nothing happens.
Reconnecting to the router states the old firmware version is still active.

I also tried to use the 'firmware from file upgrade' method (RUT9XX_R_00.06.02.2_WEBUI.bin) and the verification is successful (after uploading it), but it then tells me that the version I want to upgrade to is older than the one that is installed and it will wipe my settings if I proceed.

Firmware upgrade - verification succeeded

The new firmware image was uploaded successfully. This is the last chance to abort the firmware upgrade if required.
Click "Upgrade" below to start the firmware upgrade procedure.

Checksum: fd58e92ecaaa5ce7b5797e2cc03f83cb
Size: 11.69 MB (15.19 MB available)
Note: Uploaded firmware image version is older than current firmware version. All configuration files will be erased.

As this is remote I naturally decline, otherwise I have a 50km drive ahead of me to resurrect the system..

I'm sure this is also what happens when I do the upgrade from server - it just never proceeds, as I ticked 'keep all settings' so it right away aborts the upgrade, as the newer firmware version comes with an older date, so that it would wipe the settings.