FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
481 views 1 comments
by anonymous

I'm trying to send a text message from my TRB140, which is connected to my carrier and is online for data (I'm actually connecting to it remotely). 

From the command line, I get the following error

# gsmctl -S -s "<my number> test"
GSMCTL error: reading message
N/A

I've tried via the GUI but this produces the following error:

Any ideas on what's going wrong?

2 Answers

0 votes
by anonymous

Hello, 

Could you try re-executing this command: Gsmctl commands - Teltonika Networks Wiki (teltonika-networks.com)

And the error still persists don't reboot the device and get the troubleshoot file.

 You can get the troubleshoot file by downloading it from System > Administration > Troubleshoot 

Once downloaded kindly share with me a copy of the troubleshoot file of the device. 

Let me know the results

Regards,
Mellow

by anonymous
Thanks Mellow, I've followed your directions and I'll private message you a link to download the troubleshoot file.
0 votes
by anonymous
Just wanted to update this post in case anybody else has this issue/error in the future. It turns out that the issue is with the SIM card itself. My carrier doesn't allow data-only (home broadband style) SIMs to send text messages. So the problem is not with the router but rather the SIM.