10513 questions

12524 answers

19450 comments

22058 members

0 votes
157 views 10 comments
by

Hello. Teltonika-RUTXR1, firmware RUTX_R_00.02.06.1

I was testing SMS utilities. When edited predefined "status" command, got Error 500, when trying to set authorization to single phone number or Group.

I tried +371123456 and 1234567. 

Teltonika-RUTXR1.com - SMS Utilities

Got error:

500 Internal Server Error

Sorry, the server encountered an unexpected error.

...lua/luci/model/cbi/mobile_utilities/rule_details.lua:26: attempt to index upvalue 'io' (a nil value) stack traceback: ...lua/luci/model/cbi/mobile_utilities/rule_details.lua:26: in function '?' /usr/lib/lua/luci/cbi.lua:247: in function '_run_hooks' /usr/lib/lua/luci/cbi.lua:438: in function 'parse' /usr/lib/lua/luci/dispatcher.lua:993: in function '_cbi' /usr/lib/lua/luci/dispatcher.lua:1514: in function 'dispatch' /usr/lib/lua/luci/dispatcher.lua:537: in function

1 Answer

0 votes
by

Hello, 

Regarding the issue you are having may I know what configuration did you made in the Status tab of SMS Utilities? Could you try doing a hardware reset to the device and check if solves the issue. If the issue still persist after the hard reset I would like you to re-flash the firmware via bootloader menu you can do so by following the steps mentioned here: RUTXR1 Device Recovery Options - Teltonika Networks Wiki (teltonika-networks.com)

Kindly let me know the results

Regards,
Mellow

by

Here is step by step instruction, how to recreate this issue. The same result, if you select group of numbers.

1) Factory reset via web interface does not help. Same error.

2) Firmware update via bootloader does not work.

- Entering bootloader mode - Pass

- Start uploading RUTX_R_00.02.06.1_WEBUI.bin file - Pass

- Soon after (only 17 pings are passed after pressing "update firmware" button) router stop responding to ping and just hangs, without any changes in indication (constantly lit are power and LAN1 link).

- After power cycle I can login into normal web with my custom password what was set after normal factory reset. Wi-Fi interfaces are also disabled, so old config are intact.

- I tried 3 times bootloader update with Edge Chromium and Firefox browsers.

Step 1

Step 2

Step 3. End.

by

Hello, 

Tested it a couple of times in my side I am not able to replicate this issue: 

Kindly try doing a bootloader firmware upgrade you should be in the same window like what is on this link: 
RUTX_bootloader.png (1184×513) (teltonika-networks.com)

Kindly follow the steps mentioned here: RUTXxx Firmware via The Bootloader Menu - Teltonika Networks Wiki (teltonika-networks.com)

Regards,
Mellow

 

by

Hello. I just successefully did bootloader mode update (firefox, in private). Please add to wiki page following picture - how it must end.

Before today I just got blank browser page, so i think, download each time failed.

But, my problem still exists. I went through initial setup wizard: timezone, lan subnet, disable all wireless SIDs, save.

And still I am unable to set single phone number for "status" rule. I tried +371 xxxxxxxx and just xxxxxxxx. Error 500 are present always.

I used Edge Chromium (in normal mode) anf Firefox (in private mode). Also, I tried to modify another rule, same error.

by
Hello,

Could you send me a copy of the troubleshoot file of your RUTXR1. You can download it by navigating to System > Administration > Troubleshoot and kindly send it to me via PM.

Regards,
Mellow
by
Hello,

Regarding this issue, you are having it will be fixed in the next upcoming RUTOS 7.0 Firmware.

Regards,
Mellow
by
Thanks. What is timeframe for 7.0 firmware?

Also, as you remember, I never got fw upgrade/downgrade via bootloader. Every time it results in nothing, even when device reports what fw upgrade was in progress/started. Do I need to open new "question" about this issue?
by
Hello,

The issue is replicated in HQ currently they are working on the RUTOS 7.0 firmware as of now. For the exact timing of when will it be released, there is no specific timeline yet. But the projected date is this Q3/Q4. Only that it will vary due to bug fixes.

Regards,
Mellow
by
FYI: This bug was introduced in RUTX_R_00.02.06_WEBUI.

RUTX_R_00.02.05.2_WEBUI works fine, no error here.

P.S. I have found, what upgrade in bootloader mode works only if Ethernet port on PC are build-in. When I was using USB to Ethernet adapter upgrade was never successful. Buil-in Ethernet port with external Ethernet adapter cable (passive) are OK.
by
Hello,

Yes, the fix for this issue will be included in the new RUTOS firmware version. :)

Regards,
Mellow
by
Problem fixed in 00.07.00 firmware (22 July 2021)