subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
+1 vote
1,799 views 10 comments
by anonymous


I get new RUT240 which i want use just as Email to SMS gateway.
I configured it with instructions from Wiki Teltonika

In Network->Mobile set data from SIM: APN, PIN etc.
Checked Services->SMS Utilities->SMS Managment->Send SMS and it works
In Services->SMS Gateway->Email To SMS configured POP3 email account. I already checked Gmail (enabled POP3 in account options) and service with have native enabled POP3.
Tried send email where topic is 00048xxxxxxxxx (048 Poland counry code and xxxxxxxxx 9 digits phone number in Plus Mobile) but not received any SMS.
I tried emails with many text, short, long, with and without special characters.

In CLI i get messages like this, so i understand mail is readed
Thu Jun 24 15:05:00 2021 crond[4591]: USER root pid 22315 cmd lua /usr/bin/pop3_ets read
but nothing informing about send
Anyone have any sugestions what can be wrong ?

3 Answers

0 votes
by anonymous

I suspect that there may be something wrong with email settings. I would like to suggest to you try sending test emails to your email account first (to check if your email configuration is working).

You can send test emails in Status > Events Log > Events reporting.

by anonymous
I don't really understand what sending e-mails have to the Email to SMS service.
In Email to SMS is configured incoming not outgoing mail.

However, I tested the sending of e-mails by Events Reporting and unfortunately it doesn't work, it returns "Mail send failed".
I also upgraded firmware to latest version but it didn't change anything.
Update: Tested also on 1.14.37 firmware, still not working :(
by anonymous

Could you post a screenshot of your email configuration? (make sure to blur out any sensitive data)
by anonymous

Events reporting

Email to SMS


by anonymous

Thank you very much. 

I have tested both scenarios.

At the first time, I was unsuccessful and I have enabled non trusted devices in my Gmail settings. After that everything went smooth with these configuration settings:

Have you tried disabling the 2-way authentication factor on your Gmail account and turning on the less secure app settings?
You may refer to this links for more information:

by anonymous
I don't have 2-way autentication for this account.
Turned on less secure app but still have error when test sending.

I not only test this on gmail, tested on email where don't have any restrictions like secured apps etc. and also no working :(
by anonymous
Have you enabled POP/IMAP settings? Could you provide a screenshot as well of these settings?
by anonymous

POP is enabled, IMAP disabled

by anonymous
Please enable IMAP settings too. I had to enable it for my account before it worked.
by anonymous

Still not working on gmail.

I tried email from work and pass send test but email to SMS still not working.

In CLI i get something like that

Mon Jun 28 10:50:00 2021 crond[3502]: USER root pid 3911 cmd lua /usr/bin/pop3_ets read

Mon Jun 28 10:50:46 2021 daemon.notice netifd: ppp (3758): Mobile status MCC: 260, MNC: 1, PS: attached,


Mon Jun 28 10:51:00 2021 crond[3502]: USER root pid 4173 cmd lua /usr/bin/pop3_ets read

Mon Jun 28 10:51:07 2021 daemon.notice netifd: ppp (3758): Mobile status MCC: 260, MNC: 1, Bearer: umts,

PS: attached, traffic-channel-active

Mon Jun 28 10:52:00 2021 crond[3502]: USER root pid 4425 cmd lua /usr/bin/pop3_ets read

Mon Jun 28 10:52:51 2021 daemon.notice netifd: ppp (3758): Mobile status MCC: 260, MNC: 1, PS: attached,


by anonymous

I added a brand new email from my company mailbox. The mail is read because it disappears from the mailbox, but the SMS is not sent.

Tue Jun 29 13:39:00 2021 crond[4741]: USER root pid 9641 cmd lua /usr/bin/pop3_ets read

Tue Jun 29 13:39:04 2021 gsmd[2141]: gsmd send: 'AT+CMGS=21' (11)

Tue Jun 29 13:39:05 2021 gsmd[2141]: gsmd send: '0001000e8100406830060452000007d4e294aa50280

0' (45)

Tue Jun 29 13:39:05 2021 gsmd[2141]: gsmd get: '+CMS ERROR: 500' (15)

When, after receiving an e-mail message by the router, I manually send an SMS from it, I get an SMS on the phone with the combined content from what was in Email to SMS and what I entered in the manual SMS egzample:

EMAIL to SMS content


Manual SMS content


I received on phone SMS with



As if the router keeps in memory the content of the SMS that it should send automatically after receiving the email, but does not send it and adds it to the content of the SMS sent manually.

Is there any chance of launching this service? I have already spent too much time testing and there is still no solution. I will be forced to give up the equipment and look for another one because the deadlines are chasing me.

0 votes
by anonymous
Same problem here, doesn't work anymore with rut240 latest fw..

System Log

Fri Aug 20 10:34:00 2021 crond[24904]: USER root pid 19693 cmd lua /usr/bin/pop3_ets read

Fri Aug 20 10:35:00 2021 crond[24904]: USER root pid 20015 cmd lua /usr/bin/pop3_ets read
0 votes
by anonymous

There's a weird bug in the /usr/bin/email_to_sms lua script

line 66: change this:

        response=os.execute("gsmctl -O "..modem.." -Sb "..number)

to this:

        response=os.execute("gsmctl -O "..modem.." --sms --send-b64 "..number)

line 78: change this:

        response=os.execute("gsmctl -O "..modem.." -Sb "..number.." -L "..limit)

to this:

        response=os.execute("gsmctl -O "..modem.." --sms --send-b64 "..number.." -L "..limit)