10879 questions

12962 answers

20220 comments

26087 members

0 votes
160 views 6 comments
by

I've been using an RUT240 as a secondary WAN for my pfSense based system without problems for a couple of years. However as the firmware was old I upgraded it from v1.11.3 to 1.14.0 and immediately had issues:

  1. The RUT240 would become un-responsive (no connection to internet and web GUI not responding) after a few hours and needed a restart.
  2. The IP shown in pfSense for the interface and gateway for the RUT240 both stayed in the LAN range specified in the RUT240  rather than the cgnat IPs from the mobile service provider.
  3. Minor given the above, but the RUT240 couldn't show firmware from your servers.

After two days of experimentation and trying v1.14.1 I gave up and reverted to v1.11.3 and everything was back to normal.

So two questions:

  1. Is this a known issue?
  2. Does anyone know when this was introduced as I would like to move to the last v1.13 or v1.12 and its very time consuming to test and revert.
by
Hello,

I have a similar setup with RUT240 (in bridge mode) and pfsense. I have even older fw on RUT240 and it has been up and running for a few years without any problems.

Last week I upgraded RUT240 to latest fw but no matter what I did I could not get bridge mode working again - tried hard and soft reset but nothing worked. It does not bind the external ip from RUT mobile wan to specified mac address, instead you get an ip from RUT lan ip-range.

To me with the updated fw everything seems to work much slower than before (applying settings in gui etc.). As soon as i reverted back to old fw everything works as one would expect.

1 Answer

0 votes
by
Hello,

Thank you for contacting .

May i know what do you mean by unresponsive ?

What specific service stops working?

Thanks.

Regards,

Ahmed
by
The web GUI doesn't respond and it doesn't provide an internet service to my pfSense device

Rebooting it restores the web GUI but doesn't resolve the pass through issues I mentioned earlier.
by
Any thoughts on this?
by

Hello,

I have tried to replicate the issue on my side.

Here are my tests:

1)I keep device on older firmware 1.14.0 and i was assigned WAN IP of the router . 

2)I check on firmware updates and i was able to see the latest firmware available and i successfully upgraded the device firmware to the latest available from the server.

3)After upgrading to the latest firmware (1.14.1) nothing changed and everything worked fine for me also i was able to access the webui. 

Thanks.

by

You have misread my post as my issues occurred after upgrading from v1.11.3 to v1.14.0x (1.14.0 or 1.14.1) not between v1.14 versions:

However as the firmware was old I upgraded it from v1.11.3 to 1.14.0 and immediately had issues:

As per my earlier reply I have reverted to v1.11.3 and it works fine, and since then I've twice another upgrade to v1.14 and my setup breaks as described in my original post, but reverting to v1.11.3 and its working again.

So either either:

  • A setup that worked fine on various firmware up to v1.11.3 (I've not tried 1.12.x or v1.13.x yet) doesn't work in v1.14.x
OR
  • The migration of settings between v1.11.3 and v1.14.x is somehow broken
Have you tried my setup of 4G only in passthrough mode?
by

Hello,

Yes, i understand your issues occurred when you upgraded from v1.11.3 to  v1.14.x.

But as i have tested it on my side and it worked fine for me. 

Could you please try to upgrade device without keeping settings ? or better upgrade device in bootloader menu.

https://wiki.teltonika-networks.com/view/RUT2xx_Firmware_via_The_Bootloader_Menu

Thanks.