10513 questions

12519 answers


22044 members

0 votes
3,316 views 4 comments

I downloaded https://wiki.teltonika.lt/gpl/RUT850_R_GPL_00.01.02.tar.gz for to add some functionnalities like tcpdump, horst and cshark and compile but get this following after a couple hours of cross-compilation :

Collected errors:

 * wfopen: /home/osboxes/Desktop/RUT850_R_GPL/bin/ar71xx/packages/libbrand_1.0-1_ar71xx.ipk: No such file or directory.

 * pkg_init_from_file: Failed to extract control file from /home/osboxes/Desktop/RUT850_R_GPL/bin/ar71xx/packages/libbrand_1.0-1_ar71xx.ipk.

xargs: /home/osboxes/Desktop/RUT850_R_GPL/staging_dir/host/bin/opkg: exited with status 255; aborting

package/Makefile:99: recipe for target 'package/install' failed

make[3]: *** [package/install] Error 124

make[3]: Leaving directory '/home/osboxes/Desktop/RUT850_R_GPL'

package/Makefile:167: recipe for target '/home/osboxes/Desktop/RUT850_R_GPL/staging_dir/target-mips_34kc_uClibc-' failed

make[2]: *** [/home/osboxes/Desktop/RUT850_R_GPL/staging_dir/target-mips_34kc_uClibc-] Error 2

make[2]: Leaving directory '/home/osboxes/Desktop/RUT850_R_GPL'

Makefile:95: recipe for target 'world' failed

make[1]: *** [world] Error 2

make[1]: Leaving directory '/home/osboxes/Desktop/RUT850_R_GPL'

/home/osboxes/Desktop/RUT850_R_GPL/include/toplevel.mk:169: recipe for target 'world' failed

make: *** [world] Error 2

ps: Before to access in menuconfig i did  :

./scripts/feeds update -a

./scripts/feeds  install -a

I applied some stuff like this one but nothing : https://github.com/8devices/carambola2/issues/58

Please how to fix this issue ?

Thank you in advance.

4 Answers

0 votes

Does issue persist when you try to compile default firmware without changes?
All works with default settings.
So seems you missing something while adding packages.

Have you tried simply add your wanted packages using "opkg install" directly via SSH?

By the way, tcpdump already should be in router.
0 votes
I wanted to install aircrack-ng because lack of memory installation can't be done. OK for tcpdump i will check if it is already installed. My purpose is to turn the router in monitor mode.
Should be possible to install it via opkg.
0 votes

Yes i tried with opkg but it doesn't work because not eough memory

0 votes
After only checked HORST package i launched the compilation and it worked properly without any errors.I will try the new firmware after.
Horst works well and wifi is in monitor mode.