10879 questions

12962 answers

20219 comments

26085 members

0 votes
128 views 0 comments
by
Dear all,

My RUT950 does not start anymore. I tried to upgrade the router to 6.8.3 and never came back online.
Currently only the power-cable (no RJ45) is connected .
The power-LED goes on and the LED below the LAN3 port start blinking (flashing) immediately.

I tried to reset the router without success, using the instructions here: https://wiki.teltonika-networks.com/view/RUT9xx_Firmware_via_The_Bootloader_Menu
Serial number is 1108076935, date of purchase is 27/7/2020.

Any recommendations, workarounds ?

Thank you in advance.

Stergios

1 Answer

0 votes
by
Hi,

It seems that you could've bricked your device and there can be numerous reasons for that as too old bootloader, HW revision of the device is too old or something happened mid-process and your device shut down unexpectedly.

As you already tried doing something through the bootloader menu there's nothing more left to do just to return the device.

Please return the device to the reseller or contact us through VIP HelpDesk if you bought it from us.

EB.
Best answer