subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
383 views 3 comments
by anonymous
My operator has two BTSs on the nearest hill, First of them uses B3, the second one B20. B3 is quite good 30Mb/10Mb , but B20 is much worse, only about 3Mb/1Mb with SINR 2 dB. So I set TRB140 to use only one band - B3. But Vodafone switches its BTSs off sequentially but iregularly every night for few hours so if TRB140 is on B3 only, there is no internet for about 3 hours every night. Is there a way to set a priority for the bands? B3 as a number one, when the connection is lost, switch to B20, when B3 is available again, switch back? Or any other solution for that problem?

1 Answer

0 votes
by anonymous

Hi, please use this AT command to test if it works as you expect it to.

You can execute AT commands with gsmctl -A AT+....



<band1> Band id of first preferred LTE band, range from 1 to 43

<band2> Band id of second preferred LTE band, range from 1 to 43

<band3> Band id of third preferred LTE band, range from 1 to 43


by anonymous
Thank you for your answer. I will be by the device at the end of this week and I will test it.
by anonymous

Well, something is wrong and I do not know what.

root@Teltonika-TRB140:~# gsmctl -A AT+QCFG="lte/bandprior",3
root@Teltonika-TRB140:~# gsmctl -A AT+QCFG="lte/bandprior",3,20
root@Teltonika-TRB140:~# gsmctl -A AT+QCFG="lte/bandprior",3,20,28

I am able to display the help for QCFG using QCFG=? and lte/bandprior is on the list. I tried to set one band only, two bands and three bands with very the same result - Error. I changed manual selection of bands to automatic, error again. Is there something obvious that I am missing?

by anonymous

Yes, the problem was trivial - syntax error. So I set it and TRB140 connects to B3. But after few seconds it shifts (or is shifted) to B20. Is there any solution for that behaviour?

The command should be

root@Teltonika-TRB140:~# gsmctl -A 'AT+QCFG="lte/bandprior",3'