8853 questions

10512 answers

16486 comments

15817 members

0 votes
150 views 7 comments
by
I have made some attempts to activate the NMEA server on my RUT 955 and connect the Navionics Boating app from an iPad. The purpose is to provide the GPS data to the app through the NMEA interface. According to the Boating documentation connecting to an NMEA server is possible. I have tried all possible ways but haven't been successful to get the Boating app to recognise the RUT NMEA server. Has anyone else tried this, or have some idea on what I might have missed?

3 Answers

0 votes
by
Hi,

As I never myself tested the Navionics boating app, could you please lead me through the process that you do when trying to connect NMEA server to that app?

As of now, I would imagine that you need to connect to the NMEA server through a local or public IP address and you're probably using the wrong one, but I could be wrong too, so any information or details on how are you connecting would be appreciated.

EB.
by
Hi,

I am not with the router until several weeks from now so I will try to recreate from my memory:

- I activated the NMEA server on the RUT955. As I remember it this would include getting the IP adress for the NMEA server. (192.168.1.xxx, and port 8500)

- The in the boating app there is an option to pair a device where I input host IP address (192.168.1.xxx) and port (8500).

- There are options for TCP as well as UDP and I tried both

- The device (an iPhone) was connected to the RUT955 WiFi network

I found some information at this link for a dedicated NMEA WiFi bridge https://www.yachtd.com/news/navonics_app_sonarchart_live.html which seems to indicate that the settings should be: port should be set to 2000, using NMEA 0183 protocol, using UDP. These instructions are from 2017, and my boating app does allow setting of port, and UDP at least

Having done some more research now it is probably the Boating app that is the issue. It seems to support receiving only AIS and depth NMEA info over WiFi. I will try when I am back at the boat to connect using a more capable SW like iRegatta (https://www.zifigo.com/node/667).

If I have any progress I will update here
by
Tried with Iregatta too but no luck
0 votes
by

Hi , i have this working. There is some openwrt knowledge needed, but it is very doable.

I have it working on an rutx11 router.

You need to install kplex, amd configure it, and then do nmea forwarding to the router itself with the kplex port. Then connect your boating app to the same router and port. In the end you will have an nmea tcp proxy, so not only for the gps data but for any nmea data.

http://www.stripydog.com/kplex/index.html

by
Thank you. Not clear to me where to install kplex. My setup is to run the navigation sw ou an iPad
by
kplex is installed on the teltonika device, when done and configured (follow the link I posted earlier) you can then point your nmea forward in the routers config to the kplex (routers ip and kplex port, default 10110) then you are good to go. I am using it now with navionics and it works perfectly
by

Thanks, I think this will be my last resort as I suspect it’s too much work to build knowledge to actually make this work, the kplex instructions only make a cursory reference “ kplex has been compiled on some router OSes such as OpenWRT and Tomato.” I understand the RUT955 uses some flavour of OpenWRT. 

by

Yes it is OperWrt, trust me it seems harder then it looks. All you need todo is enter the cli of the router and do:

opkg update

opkg install kplex

then open /etc/kplex.conf in edit mode and update it with this data:

[tcp]
mode=server
port=10110
direction=both

Save the file and restart the router.
Open the gps nmea section on the router and set nmea forwarding to the routers ip address with port 10110 tcp. And then set forwarding enable on every nmea sentence you like.
On the ipad; open boating app and add a new connection to the routers ip address and port 10110 tcp.
Thats it.

0 votes
by

open your mobile device settings and select the plotter Wi-Fi (enter password, if required), then open the Boating app.

get-mobdroapk.com

get-vidmateapp.com

by
Tried that. it doesn't work. Check my comment on the first answer