8298 questions

9762 answers

15547 comments

13865 members

0 votes
96 views 0 comments
by

Hello, so i have a rut955 router setup in the following way: The rut955 router is configured as an OpenVPN client and connects to an OpenVPN server that is hosted on a Pfsense router. i have configured the OpenVPN server in a way that i can access the client (rut955) from the server in a reverse tunnel and the pfsense router gives each client in unique static ip address. This configuration has worked correctly and i have been able to read values from my PLC via the Scada system trough the openVPN tunnel. But now after i upgraded my router from firmware version "RUT9XX_R_00.06.08.3" to "RUT9XX_R_00.07.00" i am no longer able to access my plc from my scada.i am able to access the rut955 routers webgui trought the vpn tunnel from the scada system but not the plc or any other devices on my routers lan. if i create a port forward rule from WAN -> LAN i am able to access the plc remotely but not trough the OpenVPN tunnel. I have created a port forward rule OpenVPN -> Lan for port 502 and this worked with the previous firmware version. This same rule doesn't seem to allow any data to pass with this new firmware. What kind of configuration change do i need to make to get this reverse-tunnel to work with the new firmware or is this possibly a bug?

Network topologyFirewall port forward rule from OpenVPN to plc on lan

1 Answer

0 votes
by

Hello,

Please, send me the troubleshoot file via PM. You can find it in the System->Administration->Troubleshoot.

Best regards.