8401 questions

9886 answers

15681 comments

14163 members

0 votes
75 views 2 comments
by

Good Day

I am trying to build the RUT9_R_00.07.00  SDK following the README contained within the SDK folder. I am using Ubuntu 20.4 LTS. I have not made any changes within the menuconfig.

When building the image (executing the make command) the build process failed. The process fails at:

 make[2] package/install

Rerunning with higher verbosity (make V=sc) shows the follwing error:

Collected errors:

 * check_data_file_clashes: Package libqmi wants to install file /home/X/rutos-ath79-rut9-gpl/build_dir/target-mips_24kc_musl/root-ath79/usr/lib/libqmi-glib.so.5

But that file is already provided by package  * libqmi-glib

 * check_data_file_clashes: Package libqmi wants to install file /home/X/rutos-ath79-rut9-gpl/build_dir/target-mips_24kc_musl/root-ath79/usr/lib/qmi-proxy

But that file is already provided by package  * libqmi-glib

 * opkg_install_cmd: Cannot install package libqmi.

make[2]: *** [package/Makefile:68: package/install] Error 255

make[2]: Leaving directory '/home/X/rutos-ath79-rut9-gpl'

make[1]: *** [package/Makefile:120: /home/X/rutos-ath79-rut9-gpl/staging_dir/target-mips_24kc_musl/stamp/.package_install] Error 2

make[1]: Leaving directory '/home/Xrutos-ath79-rut9-gpl'

make: *** [/home/X/rutos-ath79-rut9-gpl/include/toplevel.mk:231: world] Error 2

Any advice on how I rectify this to process with the build process?  I have already tried a clean build as well as make defconfig which both return the same result.
I have noticed that there are two instances of qmi-utils in the menuconfig, however, I am not sure if it is related to the issue or how to remove them as they are preselected as a dependency to another package which I am not sure how to trace to the package that requires the dependancy.

1 Answer

0 votes
by
Hello,  could you please try wiping your current environment (also double check whether there are any hidden files left)?

Then please download newer version of GPL package from the following link:

https://wiki.teltonika-networks.com/gpl/RUT9_R_GPL_00.07.00.2.tar.gz

Extract and follow the steps in README file
by
Hi

I am testing it now and will get back here with the result :) - it is compiling right now

Felix