7855 questions

9275 answers

14928 comments

12723 members

+1 vote
71 views 2 comments
by

FW 00.07.00

Dear support team,

here is another error in this exciting new firmware version. To be honest, there are so many errors that I have to say it is neither qualitative nor is it industrial - both claims of Teltonika - yet, currently it is not Teltonika. Compared to predecessor versions the FW 00.07.00 has a degressive and poor quality, I wonder that it has been released to market! But let us come to the point.

Test installation:
I have configured an interface priority list in the order WAN, WWAN, Mobile.
I have configured an event report of type Failover.
The WAN connection of the router is configured to connect to a LAN port in my home network.
The WWAN connection of the router is configured to connect to a WLAN access point in my home network.
The Mobile connection of the router is configured for a certain operator.
Everything works well. The router is permanently connected to LAN.

Test scenarios:
Scenario 1
Covers the situation where the interfaces drop in the order of their priority as configured by the user.
I interruputed the LAN connection. Interface status changed to "not ready", WLAN interface activated. Failover message.
Then I interrupted WLAN. Interface status changed to "not ready", Mobile interface activated. Failover message.

In this scenario there is no predecessor interface which is active and thus it is necessary to switch
to a failover interface down the prio list and to inform about that via event reporting.
Test o.k..

Scenario 2 (refer to attached screenshots)
Covers the situation where an interface somewhere within the priority list as configured by the user drops.
LAN connection active and stable.
At 23:00 (pictures *_Evening_*) my WLAN automatically shuts down, while at 07:00 (pictures *_Morning_*) it automatically comes up again.
Shortly after these times I reproducible get event reports for event type = Failover.
Because the router firmly connects to the LAN, there is definitely no failover situation, while the "morning scenario" is completely crazy because the WWAN is coming up again.

In this scenario there is a predecessor interface which is active and thus there is no need to switch
to a failover interface nor to inform about that via event reporting.

1_Evening_Before_Event_Status:

2_Evening_After_Event_Status:

3_Evening_After_Event_EventsLog_Router:

4_Evening_After_Event_Email:

5_Morning_After_Event_Status:

6_Morning_After_Event_EventsLog_Router:

7_Morning_After_Event_Email:

Possible solution:
Correct the algorithm which analyses the interface status and activity (take into consideration when there is an active predecessor).
In addition to the "WAN failover" event provide a "WAN status" event. Then you can differentiate the scenarios and report correctly.
In another question I suggested to reflect the interface status in the new menu System>Overview as it was available in a sub menu of previous firmware versions.

Regards

Guenther

by

Can confirm the erroneous behavior. Extremely annoying... Any chances to fix it? Or should be downgrade because the FW 00.07.00 is buggy as hell. Highly disappointed. How can this FW be released with such bugs?

by
A drastic solution to your issue would be the use of _official_ openwrt on the RUT955. I have the same WAN/WWAN/CELL config like you on a fleet of RUT955s, running official openwrt. No such bug.

Please log in or register to answer this question.