8346 questions

9820 answers

15603 comments

14000 members

0 votes
97 views 5 comments
by

I'd like have an access to my NVR & alarm device, behind X11, with my android phone.

I've tried many combinations of IP's, but with no luck.

With following configuration (in a pic) connection is success, when Android device is connected to X11's local wifi network.

When I share an other wifi, and connection comes from internet, there's a fault, "refused to connect".

So my question is, if I could get clear IP's/setting, what to put to those fields, especially IP fields. Assuming X11 is 192.168.1.1.

This might be firewall issue, but I don't know how to open it more?

Then, as Schwabe's OpenVPN does not have exactly the same settings, this becomes more interesting. Like to have some advise to them as well if possible. Or, is there any other/better choise for free VPN?

Teltonika's "encryption" setting will clear, each time, I do any changes to VPN. I'd like to use AES-256-GCM 256, but X11 will clear this setting back to DES-CBC 64. 

Each time, I change firewall, I have to open VPN setting and "refresh" DH parameters - and encryption returns to DES-CBC 64.

X11 is running with FIRMWARE VERSION RUTX_R_00.07.00

I.

 

by

This seems to take for a while....

Every time, I add all defaults to OpenVPN configuration, device will crash.

The only way to get forward is to make >12s reset - and start from the beginning.

Sometimes it will crash after accepting settings to OpenVPN page, sometimes it hangs to define DH certificate.

Then, for example, when going through first, guided setup, device asks for new password etc. 

If I then change wifi nw name & password, it won't store password. Password has to be re inserted after reboot.

DDNS settings... looks, device has to be rebooted, before settings takes place.

If OpenVPN has same features, do I have to reboot device after each settings?

2 Answers

0 votes
by
And one more interesting feature I found.

When configuring OpenVPN in basic mode, I can get it connected.

If I change it to advanced, I can't connect anymore????

There's a one IP in local network, I'd like to connect with my android phone, but somehow I feel, I can't open ports from firewall in order to have an access?

In basic mode, I can't see that possibility, and in advanced mode I can't test it, as I can't connect anymore.

This time it didn't crash, after certificates were created. Is it because of basic mode?

If there's any chance to make such a configuration, this unit will connect with OpenVPN & Schwabe OpenVPN, I really appreciate to get some working settings, how to configure this.
by

Continues.... After numerous hours of playing, I realized it's a lottery, when X11 accepts advanced settings in a way, I'm still able to connect via OpenVPN.

I was able to play with firewall/port settings for a while, but then I changed encryption from DES-CBC 64 to AES-256-GCM 256... and state is "inactive", and... don't know how to get it up and running. Pretty tired now.

Encryption setting returns always "automatically" back to DES-CBC 64.

Firewall settings... sometimes when I do some change to a setting which was accepting connection, it denies connection and after changing it back, it accepts it again. Sometimes. usually not.

So, in order to test any change, X11 seems to require a reboot.

I was able to get so far, I saw X11 at 192.168.1.1. Even, doing no changes, or trying to change something/get back to original, sometimes I can connect to X11, sometimes not.

That leads to a fact, even I know, I should have a connection with some settings, I can't be sure if any other settings are correct or not in order to get connected to a device at 192.168.1.106.

I've been trying to open/forward all the ports, did some routing settings, but no matter what I try, there's no connection to IP ...106.

After I've seen how this unit handles changes, I'm not sure anymore, if I've tried right settings or not.

So, again, could I get all required settings in order to connect to ...106 (in this case) through OpenVPN . Schwabe.

I haven't won anything from a real lottery either.

By the way, in order to make OpenVPN "active" again, I had to get in to the configuration, switch "Certificate files from device" off and on, and save it... (sometimes...)

by

Hello,

We can verify that there is an issue with encryption getting reset to default settings and we will fix it with future firmware releases.

Also, I would like to ask you to insert Push option value "route 192.168.1.0 255.255.255.0" and you should be able to reach devices in your router LAN.

Regards.

0 votes
by

OK, I tried push option...

First of all, after playing with settings for a while, I can connect now, as I've seen it.

But, even I restore settings, I still have to play with VPN&FW settings, as I don't know why it doesn't connect.

Then, after half hour or two days, connection returns??? With same settings!!!

OK, after connection is possible, I added push option as advised.

That means, OpenVPN goes to inactive state. To get it active...playing goes on.. and on.. and on... Most often, after changing encryption to AES-256-GCM 256 I have to turn "Certificate files from device" on/off and save. After doing this for 4..27 times, (it depends on stars on the sky...??) , VPN turns back to active state, and I am able to test it.

As You guessed, I can't establish connection to my ...106 device.

Port forwarding are from "any", 0-20000, to ..106.

X11 itself is reachable, so I can go in to the X11 settings via 192.168.1.1.

Whatever I'll do for the settings, result is that VPN turns to inactive mode, then the play starts from the beginning....

As I mentioned, even restoring settings from the backup, I can't connect, without playing with the VPN "saving".

This takes years to find out, what I'm missing, as even working connection might disappear when touching to some other settings. To me this looks like I have to be able to set all the right settings at once, then I might be lucky.

Do I have to make factory reset between any change, is a bit unclear so far, as I haven't got time to play with this that much.

(Now I know I can't create certificates one by one, otherwise X11 will get stucked, and factory reset is the only way to get forward...)

That's why I asked for each setting for both X11 & Android - so that I can put them correctly at once. 

by
Last night, I figured out one more interesting feature.

Previously, I thought, X11 crashed after certain settings. Might be true, but there's an other chance.

I got a laptop attached to my home network which comes from X11. So, locally to 192.168.1.1, I added and saved a client for Openvpn. (lower part of openvpn settings page). When I saved it... Access to X11 was cut off.... So, no connection with my laptop to X11. No internet access either.

BUT, I was able to get in with my phone!! Via internet!

I went in to X11, disabled openvpn, saved it.... Then internet connection returned to my laptop (and other devices) and I had local access to x11 with my laptop.

Then I closed the lid of my laptop and went to bed.
by

If this has been tested, and proved as a working device, could I get exact settings for one device, behind X11, with certificates.

In order to check every possible settings for firewall, for example, will take forever, as to me this looks like I have to delete all settings and create a new VPN + all other settings, before this device accepts them.

For example, this unit will create automatically traffic rule for OpenVPN. I might be able to make a connection with those settings. Let's assume, I won in a lottery, and got connection. Then, I do a change to this rule, I will lose connection. That's OK. BUT, if i change it back to original, I WON'T GET CONNECTION ANYMORE!!!!

What I've figured out, I have to delete all settings/rules I've made for OpenVPN and create them again. Then I might get connected.

This leads to a fact, I can never be sure, was that setting, I tried, correct or not, as I don't know whether X11 accepted it on not.

If You could confirm, this does not work at all with Android OpenVPN, I can return this immediately.