subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
290 views 1 comments
by anonymous

Everything seems to work fine and it has been used daily for several months.
I wanted to setup a VPN, but before I got started I noticed that all log entries was gone. 

"No entries in Status->Events Log->All Events"

I tried to do a reboot and even this was not seen in in the reboot log in the GUI.

Checking Troubleshooting->system log, I found this line:

local1.crit EventlogD[2634]: sqlite3 query error: database or disk is full

Tried to do a firmware upload, saying NO to keep settings. It spend quite some time deleting, upload the firmware and reboot.

On a "clean" system, doing a reboot is still not shown in the log and I still see the same error during boot.

What can I do to Clean/Delete what ever is causing the "database or disk full" issue?

Thanks, Dannie

1 Answer

0 votes
by anonymous

I apologize for the late reply. I would like to ask which firmware and device model are you currently using?

by anonymous

Latest available firmware on RUT850.

Eventlog just stopped recording anything and reported "database or disk is full" after being running (untouched) for months without issues?

I found this in the community, after spending hours of searching the many questions and answers about eventlogs.
(PS: I think that at least 50% of these questions could be solved with this.)


1. SSH into your router 
2. Go to log folder using command: cd /log/
(I stopped the service just to be safe: /etc/init.d/eventlog stop )
3. Run command: rm log.db
4. Run command: /etc/init.d/eventslog restart  (or start if you stopped if first )

Everything now works as expected again :-)

Regards, Dannie