FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
154 views 2 comments
by anonymous
I have a RUT955 (FW Version 00.07.00) with a SD card used for memory expansion and an USB stick used for a samba share.

The memory expansion works well: the block device /dev/mmcblk0p1 is mounted on /overlay and seems it is working.

The USB stick itself seems to work as well. The block device /dev/sda1 is mounted on /mnt/sda1.

But when I try to configure a shared directory in the Samba server (Services > Network Shares > Shared Directories), the destination path always jumps to the path /overlay. I choose the path /mnt/sda1 (USB stick), save the configuration, switch the view to another page (e.g. USB Tools > General). When I siwtch back to the view Network Shares, the path is changed to /overlay again.

Am I doing something wrong? Or what´s going on here?

Regards, Widi
by anonymous

Addition: Apparently the error is only in the configuration UI (WebUI). The samba services are obviously configured correctly (via the share I can access the content of the USB stick). 

But I always have to pay attention to the path in the WebUI. Wenn I recall the view Network Shares, the wrong path is shown and will be used, when I click Save & Apply.

2 Answers

0 votes
by anonymous
Hello,

Could you share a few screenshots that demonstrate this issue, I would like to report it to our RnD department to fix it as quickly as possible.

Regards.
0 votes
by anonymous

A few screenshots:

The desired settings for the network shares

Network Shares: desired settings

That´s working so long. When I press [Save & Apply], the correct network shares are selected. See the following extract of smb.conf:

smb.conf: correct path

Select another view

I switch to the page USB Tools > General

USB Tools > General: everything looks well

Everything looks well here.

Switch back to Network Shares

... and the setting path of the network share was changed.

Network Shares: shows the wrong path

The configuration of the network share has not been changed up to this point:

smb.conf: correct path so long

However, as soon as I press the button [Save & Apply], the wrong setting is applied:

smb.conf: wrong path in samba configuration

by anonymous
Thank you very much, your contribution is appreciated.

Regards.