subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
331 views 5 comments
by anonymous
Hey all
I've setup/installed an RUT240 as a replacement to satellite internet for a family friend. So far it has been flawless with the exception of Netflix which completely stops working on all devices on the LAN. All the other streaming services and general internet browsing works fine when the problem is occuring. Rebooting the RUT240 fixes the issue temporarily but re-occurs generally within a few hours. It's quite literally only Netflix and occurs on all devices connected to the network. I had discovered people ran into issues when DNS rebind protection was active and so I disabled it, but the problem returned the following day.
I've updated firmware, tried static IPs and DNS settings. I'm getting kind of desperate so any help is much appreciated.

EDIT* Just in case anyone comes across this in the future I wanted to provide a final update. In the end it was the operator, specifically Optus in Australia. I tested a Telstra sim and the router worked perfectly for 3 days straight (including netflix). I've also noticed the connection is considerably more stable as well. I spent hours trying to get the Optus sim to work, but in the end it wasn't worth anymore of my time.

1 Answer

0 votes
by anonymous

Could you double-check if your operator does not block Netflix specifically? This sounds like a service block from the operator side.

by anonymous
I will double check, however the operator advertises Netflix streaming on their website over mobile services so I'm not sure that will be the issue. I will confirm this though. Thank you
by anonymous
Just confirmed with service provider, they do not block or restrict Netflix in any way over their network.
by anonymous

Which firmware version does your RUT240 uses? Could you try to reinstall it to the latest RUT2XX_R_01.01.14.3 via the bootloader menu? There are the instructions:

Let me know about the results.

by anonymous
Firmware is up to date. I cannot confirm if it was done via the bootloader menu. I'll attempt to get this done within 24hrs and post an update. Thank you.
by anonymous
Update: I've relaced the router with a temporary one, different brand which has been working flawlessly. Currently have the 240 on my desk. Netflix worked initially but has since stopped. Have updated firmware as per your instructions. Have also tried custom DNS to google etc. Seems to be any service related to netflix is blocked. I've noticed I do not need to reboot the router, only re-register the mobile connection settings if that's of any help.