FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
145 views 0 comments
by anonymous

Hello,

I have tried to build the SDK in some ubuntu configurations, but I have no success.
I install the ubuntu to a VMWare virtual machine all tries. Never update it, just run the commands from your page: RUTX Software Development Kit instructions - Teltonika Networks Wiki (teltonika-networks.com)
I mean, this site is not up to date.
I have tried on Ubuntu 16.04.7. The GCC was old (5.4.0) and the SDK requires a newer one (>=6.x).
I have tried on Ubuntu 18.04.5. The build can't find node and npm. I can get the nodejs package via apt update, but the npm package not.

Could you write the steps to build your sdk package in a virtual machine with any ubuntu version?
Install Ubuntu. Which version? Update it or not? apt update, apt install, which packages? (nodejs? npm?) etc...

Thank yo for your kind help:
Zsolt

1 Answer

0 votes
by anonymous
Hello,

Please wipe your current GPL folder, extract it again and you should find a README file with additional instructions / required dependencies for the current GPL release. Please follow the instructions closely and you should be able to compile the firmware.