10909 questions

13001 answers

20269 comments

26789 members

0 votes
75 views 4 comments
by

I have multiple devices with "TRB1410_R_00.01.06.1" version and can see "Enable JSON RPC" under SYSTEM > ADMINISTRATION > ACCESS CONTROL.

But this option is gone in 07 version. 

I wen't thru the change log and can't see anything related to this.

1 Answer

0 votes
by
Hello,

JSON-RPC is enabled by default at this moment with the the7.0 version. We are planning to return this button with a 7.2 firmware release.

Regards.
by
Thank You!

I will test this out
by

It seems that there are some other changes, I am unable to write to file as I was before.

I get error of Access denied. Is there anywhere in WebUI I need to give additional permissions?

send [

  '2bc6485738f411a7861e7d90ecd25a0f',

  'file',

  'write',

  {

    path: '/home/root/test_file.sh',

    data: `test data`

  }

]

by

Hi,

There are additional changes implemented at this moment:

You will need to edit rpcd config:

config login
	option username 'admin'
	option password '$p$root'
	option group 'root'
	list read '!superuser'
	list read '*'
	list write '!superuser'
	list write '*'

and remove ! symbols from superuser. Once you change the config and save changes, apply the command:

/etc/init.d/rpcd reload

by

It seems to get a bit further, but still doesn't write the file.

Got this response:

data: { jsonrpc: '2.0', id: 1, result: [ 4 ] }