FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

11942 questions

14217 answers

22412 comments

35319 members

0 votes
558 views 8 comments
by

I am using a RUT240 in Japan.

When I insert a Softbank SIM card, the RUT240 shows "SIM (not inserted)" and I cannot use the internet from this timing.

After testing various conditions, I found out that in my environment, the problem occurs when I do the following: 

  1. inserting a Docomo SIM card
  2. inserting a SoftBank SIM card
  3. The message "SIM (not inserted)" appears, and after that, no matter whether I insert a Docomo SIM card or a SoftBank SIM card, I cannot communicate.

Then I found a temporary solution to this and will share it with you.

I went into the CLI and used gsmctl to see what was going on inside.

root@Teltonika-RUT240:~$ gsmctl --simstate
unknown

Probably the result of the AT command is not parsed, so I'll look at the EC25 manual and run the AT command directly.

root@Teltonika-RUT240:~# gsmctl --at "AT+CPIN?"
+CPIN: PH-NETSUB PIN

We found out that Network Subset Personalization is engaged. Therefore, run the AT command to remove it.

root@Teltonika-RUT240:~# gsmctl --at "AT+CLCK=\"PU\",0,\"12341234\""
OK

After that, the message "SIM (Ready)" was displayed and the problem was fixed successfully.

The following can be inferred from the above.

  •  The EC25 is incompatible with SoftBank and the module is locked.
  •  The lock can be removed by executing the AT+CLCK command.

So, here is my question.

  •  Is this problem of the SIM card not being recognized a specification of the RUT240?
  •  This problem can be temporarily solved by user script, but can it be fixed by firmware update?


SoftBank is one of the three major mobile carriers in Japan and has a large market share.

I think it would have a big impact to fix this.

Thank you for your time.

3 Answers

0 votes
by

Hello,

I would like to ask which router firmware version are you using? Also, which modem firmware version too (you can find out modem version by using gsmctl -L in SSH/CLI).

Regards.

by
Hello

I have a similar problem with my RUTX12.

Suddenly on oct. 2 2021 at 2100 the internet connection through the sim card stopped working. In the configuration for primary modem it says DDATA CONNECTION  "Disconnected".

I moved the sim card to another router and the card works fine. I check in the system log and I find this:

send to gsmd 'AT+CPIN?'

get from gsmd '+CME_ERROR:SIM not inserted

I updated the firmware to RUTX_R_00.07.00 but the problem remain.

The original firmware was RUTX_R_00.02.05.1 has been upp and running for 10 months with no problems and no changes in the setup. I have saved a troubleshoot file that I can send if you contact me on lgu@promare.se

I also called my internet provider Tele2 and they coud see that the sim card was connected to their network while RUTX12 says disconnected.

Regards

Lars
by
Firmware versions are as follow:

Router Firmware: RUT2XX_R_00.01.14.3
Modem Firmware: EC25JFAR06A05M4G

For checking this problem, I also tried to use RUT2XX_R_00.01.13(1 year old version), RUT2XX_R_00.01.14.1(previous version).
But in any case, the results were same.
by
Hi,

I have sent instructions via private message.

Regards.
by
Dear VykintasKuzma

Thank you!

The problem was resolved by following your instructions(firmware updating)!
by

Hi VykintasKuzma

I have the same Problem, Japan SIM Card (Softbank), RUT2_R_00.07.02.1

Modem:

EC25

FW version

EC25JFAR06A05M4G

Already set to factory defaults

Maybe the manual? update of the modem FW will solve this? Any advices?

Thank you and Best Regards

by

Hello,

Before updating modem firmware, you need to connect your router a different WAN source, either wired or wireless. Below are the the instructions:

Access your device via SSH and execute the following commands:

  • opkg update
  • opkg install modem_updater
  • opkg install sshfs
  • modem_updater -g

The last command will list available firmware versions. Next modify the following command:

  • modem_updater -i <ID> -v <VERSION>
    • <ID> - should be 1-1, however, in case of an error you should be shown a correct ID.
    • <VERSION> - enter the latest firmware version from the list of the previously executed command, it should be EC25JFAR06A06M4G, but from the list available double check it.

Best regards

by
Hi ZygimantasBliu

thank you for the fast answer, is there any chance to update the software of the modem offline?

We have only one ISP port which is already in use, at this remote locatation, and mobile is not working.

Many thanks and Best Regards
0 votes
by

Dear VykintasKuzma,

I have the same proble with my RUT240. 

See attached images.

Thanks

Domenico

by
Good day to all, we have the same problem, anyone have resolved? We appreciated your feedback.
0 votes
by
After using Softbank's SIM, DOCOMO's SIM no longer recognizes the SIM card as written.

It recovered by SSH command as above.

Thank you for the useful writing! !!

I lost the time of the day today. .. ..