FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
988 views 1 comments
by anonymous

I recently enabled the SNMP agent on my RUT950. When adding the SNMP Service Settings on the Services/SNMP/SNMP Settings page, I found that if I included space characters in the value entered for Location, then when I selected Save what I had entered for Location was ignored, i.e.

  • the previous value was displayed for Location,
  • an SNMP request for sysLocation.0 returned the previous value;

If I entered a value for Location that did not include spaces, it was accepted: being both displayed in Services/SNMP/SNMP Settings  after selecting Save and returned by an SNMP request for sysLocation.0.

As I read the RFC1213 and its references, sysLocation is of type DisplayString, which allows all printable ASCII characters (if not more).

So, my questions is: is there a reason to restrict the value of Location in this way, is it a bug, or am I missing something?


From Status/Device, my RUT950 device details are:

  • Serial number 1101410923
  • Product code RUT950MG1XXX
  • Batch number 0065
  • Hardware revision 1307

From System/Firmware, I have:

  • Firmware version RUT9XX_R_00.06.00.2
  • Firmware build date 2019-03-07, 13:49:36
  • Kernel version 3.18.44
  • Bootloader version 3.0.1

1 Answer

0 votes
by

Hi,

Have you tried to set that parameter via SSH?

Via SSH using vi editor you could change it and check if it works with your system.

vi /etc/config/snmpd

In order to edit the file, you have to be in insert mode. Press i

In order to get out of vi, you have to be in command mode. Press [Esc] (the escape key).

Then write one of the following command:

:x   - exit and save.

:q! – exit without saving.

then /etc/init.d/snmpd restart

by anonymous

Thanks. I did that and was able to save a Location string that includes spaces.

The web UI still does not allow me to change it to anything that includes spaces, but it does preserve it if I change other fields on the same screen, so I am able to set it to its correct value and it stays that way.

By the way, I found that it was not necessary to do "/etc/init.d/snmpd restart" for the change to take effect - the new Location is visible from my Mac Book using snmpget without the restart.