subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
488 views 9 comments
by anonymous

Hello, I'm trying to compile firmware from SDK for RUTX09, from this archive: RUTX_R_00.07.00

Unfortunately, when running make, I encounter some errors and firmware fails to build. I'm running this on Ubuntu 16.04 virtual machine. Can you help me get this working?

It finished with following errors: error: required file './README' not found

bstring/ installing './depcomp' error: required file './README' not found

Makefile:167: recipe for target '/home/user/rutos-ipq40xx-rutx-gpl/build_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/coova-chilli-e50fb309cfd1008f1e53c960ce3779ff0e9e732f-2021-06-22/.prepared_6e2247f6098d505d0ee7f7d40cb56de6_6664517399ebbbc92a37c5bb081b5c53' failed

make[3]: *** [/home/user/rutos-ipq40xx-rutx-gpl/build_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/coova-chilli-e50fb309cfd1008f1e53c960ce3779ff0e9e732f-2021-06-22/.prepared_6e2247f6098d505d0ee7f7d40cb56de6_6664517399ebbbc92a37c5bb081b5c53] Error 1

make[3]: Leaving directory '/home/user/rutos-ipq40xx-rutx-gpl/package/teltonika/coova-chilli'

time: package/teltonika/coova-chilli/compile#3.70#0.20#4.08

package/Makefile:123: recipe for target 'package/teltonika/coova-chilli/compile' failed

make[2]: *** [package/teltonika/coova-chilli/compile] Error 2

make[2]: Leaving directory '/home/user/rutos-ipq40xx-rutx-gpl'

package/Makefile:119: recipe for target '/home/user/rutos-ipq40xx-rutx-gpl/staging_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/stamp/.package_compile' failed

make[1]: *** [/home/user/rutos-ipq40xx-rutx-gpl/staging_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/stamp/.package_compile] Error 2

make[1]: Leaving directory '/home/user/rutos-ipq40xx-rutx-gpl'

/home/user/rutos-ipq40xx-rutx-gpl/include/ recipe for target 'world' failed

make: *** [world] Error 2

I created README file in some directories, but it didn't help:

touch rutos-ipq40xx-rutx-gpl/package/teltonika/coova-chilli/README

touch rutos-ipq40xx-rutx-gpl/build_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/coova-chilli-e50fb309cfd1008f1e53c960ce3779ff0e9e732f-2021-06-22/README

touch rutos-ipq40xx-rutx-gpl/package/README

1 Answer

0 votes
by anonymous


Use a recent Ubuntu version (20.04 LTS), and execute ./scripts/feeds update -a after unpacking the SDK.


by anonymous
I tried to use 20.04 LTS and always execute the command before do "make", but it doesn't help
by anonymous

Your Ubuntu OS is probably missing one or more optional packages, as per the README:

$ sudo apt update
$ sudo apt install build-essential ccache ecj fastjar file g++ gawk \
          gettext git java-propose-classpath libelf-dev libncurses5-dev \
          libncursesw5-dev libssl-dev python python2.7-dev python3 unzip wget \
          python3-distutils python3-setuptools rsync subversion swig time \
          libffi-dev xsltproc zlib1g-dev u-boot-tools nodejs npm
by anonymous

I installed all above packets, but the problem is still the same:

Also i have set the following variables in etc/environment:



by anonymous
Your download of cova-chilli-* fails. Why ?
by anonymous
Idk why, you tell me please

I just followed instructions
by anonymous
Do you have any thoughts about that ?
by anonymous
I'm trying to compile with the most recent SDK, coova-chilli download/compilation just failed. I'll look at the differences with the previous versions.
by anonymous

I have a workaround for this issue, it is due to missing files.

Download coova-chilli-1.4.tar.gz from and extract it in packages/teltonika

Then: make pakages/teltonika/coova-chilli/compile, it should work.

Unfortunately other packages also fail (easycwmp ...) and the SDK compilation doesn't complete.

@Teltonika: this SDK is corrupt, please fix it.

by anonymous

Thank you, coova-chilli is okay now, but yes, got problems with easycwmp

Have you some old SDK version which work well ?