8401 questions

9886 answers

15682 comments

14163 members

0 votes
87 views 3 comments
by
Hello,

I have tested wireguard VPN on RUT955 router from the box, everything worked fine with old as well as RUT9_R_00.07.00 Firmware version. however when I tried to changed the Wireguard Interface key and peer key, I have started having problems for having successful wireguard VPN connection.

The new problem is I have added  Interface and peer under VPN>Wirguard but once I pressed save & apply button it disappears from there(see attached image shows no tunnel added). The VPN server ping reply is destination host unreachable, may be router not saving the wireguard details. I have updated firmware to RUT9_R_00.07.002 and RUT9_R_00.07.00 couple of times as well as reset the router to factory settings but result is same. I could not roll back to older firmware(below 07.00) the firmware file I downloaded from your site says it does not support while upgrading firmware.

any help appreciated.

Thanks

1 Answer

0 votes
by
Hello,

Could you write down a step by step instructions on how you reproduce the issue (I will try exact same method)? Also, please attach a troubleshoot file from your router when the issue is present.

Regards.
by

Hi,

I have followed below steps:

1) Upgrade the old firmware of router with RUT9_R_00.07.00

2) Added  Wireguard package from package manager

3) Configured Wireguard interface only enter Private Key, keep port same 51820,  ip address (not generated public key)

4) Added wireguard peer added key and allowed ip addresses.

5) Save and apply wireguard settings, it shows tunnel on page, turn on tunnel everything worked fine

6) Tried steps 3 to 5 again only changes are wireguard interface key and wireguard peer key. The problem started with connections.

7) I have tried restart router, add another instance of wireguard nothing worked

8) Upgraded the router firmware from server RUT9_R_00.07.002. not sure if it finished successfully, after reboot, I can see wireguard package was installed but could not see wireguard page under VPN so I have uninstalled wireguard package and repeated steps 2 to 5 but it does not show added tunnel on wireguard page.

9) Factory reset the router and upgrade the firmware from file to  RUT9_R_00.07.00. same result as step 8

I can not upgrade the firmware to old version, when I browse the file it says file image is not correct. Can you please email me correct file for old version please?

I will send you troubleshoot file by email

Thanks

by

Hello,

You can find all the RUT9 firmware images right there: https://wiki.teltonika-networks.com/view/RUT955_Firmware_Downloads_(legacy_WebUI)

Also, if WebUI does not allow you to upload an old image, please try it via the bootloader menu: https://wiki.teltonika-networks.com/view/RUT9xx_Firmware_via_The_Bootloader_Menu

Please try using upload RUT9_R_00.07.02 version via bootloader too.

Regards.

by

Hello,

Updates for you: 

I have successfully managed to roll back to old firmware (RUT9_R_00.06.08.3 ) via bootloader and configured Wireguard interface and peer. Wireguard VPN connection works fine now.

 I have not tried to upgrade latest firmware so far as I am busy however I still think there is bug in RUT 7 firmware which needs to address. You can try above steps to create the issue of wireguard interface and peer disappears once you press save & apply button. 

I hope you can find solution and update us in future if possible. 

thanks for your help