FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
223 views 0 comments
by anonymous
  • Model: RUT955  
FW: RUT9XX_R_00.06.08.5


Hello together, 

I'm struggling to restore a modified Backup. Version and Model are mentioned above.

Steps i take: 


 

1. Download tar.gz, unzip it (7ZIP)

2. edit the /etc/config/strongswan file (only change the "

option my_identifier" option)
3. save the file, tar the file, gzip the file. 
4. Upload it to the Router, confirm sha/md5
5. get this error:
  • /usr/lib/lua/luci/dispatcher.lua:224: Failed to execute call dispatcher target for entry '/admin/system/admin/backup'.
    The called action terminated with an exception:
    /usr/lib/lua/luci/controller/admin/system.lua:215: attempt to perform arithmetic on a nil value
    stack traceback:
    	[C]: in function 'assert'
    	/usr/lib/lua/luci/dispatcher.lua:224: in function 'dispatch'
    	/usr/lib/lua/luci/dispatcher.lua:98: in function </usr/lib/lua/luci/dispatcher.lua:98>
I've tried every possible option in 7ZIP, there is no error message, its unzipped / zipped as admin, filesize is identical and the Syntax is correct. I want to use this option to modify / prepare configurations for multiple routers. What am i doing wrong? I've tried it on older FW Versions and on the most recent version. Thanks in Advance

1 Answer

0 votes
by anonymous

Hello

Thanks for contacting TELTONIKA | Crowd-support forum.

It seems that you are using Windows to modify backup file, please try to use Linux, you can use VM to install Linux on Windows computer.

Here’s the link to download Ubuntu 16.04 OS http://releases.ubuntu.com/trusty/

Using Linux, you can simply open backup file, change the continent of it and save, then upload the backup file back to the router after moving it to windows again.

Should you need any additional information please let us know.

Best regards.