FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
+1 vote
641 views 5 comments
by anonymous
Hello,

i want to use the TRB 142 to send and receive SMS over RS232.

If the RS232 configuration is set to modem (partial control mode), i get cyclic AT data (+QCSQ, +CMTI), but any AT-commands are accepted. The mobile connection starts automatically after reboot.

If the RS232 configuration is set to modem (full control mode), AT commands are accepted and the modem forward incoming SMS data  to the serial port, but the mobile connection don't start automatically after reboot. It`s possible to create a script to manage the mobile connection in this mode?

Thanks!
by anonymous
Did you try in partial control mode with AT commands ending with CR+LF (instead of just CR)?

I just found that CR+LF is required unlike in full control mode where just CR works. (FW ver 00.07.02)

1 Answer

+1 vote
by anonymous
Hello,

I am glad to hear that everything works as expected, except mobile conenction. I would like to ask do you use manual or auto APN settings? Could you share a troubleshoot from your router? Download it from System > Administration > Troubleshoot only when you reboot the router, wait for a few minutes and the connection does not come up.

Regards.
by anonymous

Hello,

thank you for the fast answer.

In partial control the connection mode is set to AUTO.

In full control the setting page Network/Mobile is missing, so i can't control it.

Note: all Led "Signal Strenght" are blinking

A few minutes after Reboot the Web Interface don't refresh and it can't login anymore.

Regards.

troubleshoot

by anonymous
Hello,

did you find the failure in the troubleshoot?

Is there anything else i should try?
by anonymous

Hi, 

I also have the same problem. I am using the modem with a particular software that initialises the modem via AT commands and to do this I have to set the mode to full control. 

After rebooting the "Signal Strength" are blinking. 

I cannot connect to the modem via VPN because the data network is blocked. 

How can I reactivate the data?

P.S. 

The APN is set to manual but it makes no difference if I set it to automatic. 

Here you can find the troubleshoot: https://pastebin.com/7DUNuSW4

by anonymous

There seems to be a modem hardware failure as logs are spammed with following entries:

Tue Sep 20 14:10:46 2022 daemon.info gsmd[4433]: gsmd[exec_cmd():583]: Modem not found...

Tue Sep 20 14:10:46 2022 daemon.info gsmd[4433]: gsmd[find_modem_vidpid_by_id():752]: Modem not found...

Tue Sep 20 14:10:46 2022 daemon.info gsmd[4433]: gsmd[find_modem_vidpid_by_id():752]: Modem not found...

Tue Sep 20 14:10:46 2022 daemon.info gsmd[4433]: gsmd[find_modem_vidpid_by_id():752]: Modem not found...