10490 questions

12505 answers

19431 comments

21988 members

0 votes
125 views 3 comments
by
Hello,

i want to use the TRB 142 to send and receive SMS over RS232.

If the RS232 configuration is set to modem (partial control mode), i get cyclic AT data (+QCSQ, +CMTI), but any AT-commands are accepted. The mobile connection starts automatically after reboot.

If the RS232 configuration is set to modem (full control mode), AT commands are accepted and the modem forward incoming SMS data  to the serial port, but the mobile connection don't start automatically after reboot. It`s possible to create a script to manage the mobile connection in this mode?

Thanks!
by
Did you try in partial control mode with AT commands ending with CR+LF (instead of just CR)?

I just found that CR+LF is required unlike in full control mode where just CR works. (FW ver 00.07.02)

1 Answer

0 votes
by
Hello,

I am glad to hear that everything works as expected, except mobile conenction. I would like to ask do you use manual or auto APN settings? Could you share a troubleshoot from your router? Download it from System > Administration > Troubleshoot only when you reboot the router, wait for a few minutes and the connection does not come up.

Regards.
by

Hello,

thank you for the fast answer.

In partial control the connection mode is set to AUTO.

In full control the setting page Network/Mobile is missing, so i can't control it.

Note: all Led "Signal Strenght" are blinking

A few minutes after Reboot the Web Interface don't refresh and it can't login anymore.

Regards.

troubleshoot

by
Hello,

did you find the failure in the troubleshoot?

Is there anything else i should try?