subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
203 views 0 comments
by anonymous
I have read every article here i think. I am trying to connect a device to either the lan or wan, and no matter which i choose, as soon as i plug ethernet in, the mobile disconnects, immidiately, exact cause and effect, which is great, i know what causes it, however no matter how many settings i try nothing resolves it. I tried a second device, and nothing. I tried firmware.07.01 (the new one) and it disable my hotspot having wifi access, compounding the problem, which was another rabbit hole, so i downgraded to 14.4 and wifi came back, however i still cannot use either port on the front. My friend had this RUT240 for a week with the exact same device plugged in and worked great, so i expected it to be flawless, i uploaded his configuration after downgrade of firmware and still no luck. I have the troubleshooting file and will send ASAP, please message me back. Signal strength good, im only testing all devices right next to each other.

1 Answer

0 votes
by anonymous


Thank you for your query. I would suggest trying to upgrade firmware via the Bootloader menu. Instructions on how to do this can be found here:

If the Bootloader method doesn't help in any way, please generate a troubleshoot file. I'd like to ask you to plug in Ethernet cable into your RUT240 port, wait until your device loses connectivity to the internet and then generate the troubleshoot file. Once you have your troubleshoot file, send it to me via private message.

Instructions on how to generate troubleshoot file:

A Troubleshoot file contains a device's event logs, configuration files and other info useful for diagnostics. It can be downloaded from your device's WebUI, Troubleshoot page:
System → Administration → Troubleshoot

Additional information about this process can be found here:

Best regards,