8848 questions

10504 answers

16465 comments

15792 members

0 votes
57 views 1 comments
by
Hello,

I have RUTXR1 with two WAN ports. As primary is (WAN) with a non public address and backup is with a public address (MOB1S1A1). How do I set a strictly OpenVPN server only to the Mob1S1A1 interface? OpenVPN server only works when the WAN interface is down. I am using load balancing mode.

1 Answer

0 votes
by
Hi,

This will not work because there is no mechanism for binding OpenWRT to a specific interface.

Best regards.
by
Hello,

Maybe I can't bind OpenVPN Server with a specific interface, but I can bind the server to a specific address. I added the line " option local 'xxx.xxx.xxx.xxx' " to /etc/config/openvpn file where "xxx.xxx.xxx.xxx" is a public address MOB1S1A1 interface and it already works.