FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
373 views 3 comments
by anonymous

Hello,
on RUT240 with new FW RUT2_R_00.07.01, the following firewall custom rules does not work:

iptables -I output_rule -o wwan0 -p udp -m udp --dport 53 -m string --hex-string "|04|pool|03|ntp|03|org" --algo bm -j ACCEPT

The same rule on the old FW (RUT2XX_R_00.01.14.3) worked fine.

When I force /etc/init.d/firewall restart, I got the following error:

 * Running script '/etc/firewall.user'
iptables v1.8.7 (legacy): Couldn't load match `string':No such file or directory
Try `iptables -h' or 'iptables --help' for more information.

I have tried to manually install the Openwrt package https://openwrt.org/packages/pkgdata/iptables-mod-filter but the device does not allow it.
How can we solve it?

Thanks,
M
by anonymous
Hello,
any feedback on it?

Thanks,
M
by anonymous

Hello,
I am testing the new firmware RUT2_R_00.07.02.1, since I see that in the changelog this issue should be solved: https://wiki.teltonika-networks.com/view/RUT240_Firmware_Downloads
However, it seems that the issue is still present:

* Running script '/etc/firewall.user'
iptables v1.8.7 (legacy): Couldn't load match `string': No such file or directory

Am I missing something? 

1 Answer

0 votes
by anonymous
Hello, Massimo!

We already noticed this issue. It will be fixed in future firmware release.

Thank you for information!

For now I will provide a test firmware for you in PM.

Best regards, Aliaksandr!
by anonymous

Hello,
I am testing the new firmware RUT2_R_00.07.02.1, since I see that in the changelog this issue should be solved: https://wiki.teltonika-networks.com/view/RUT240_Firmware_Downloads
However, it seems that the issue is still present:

* Running script '/etc/firewall.user'
iptables v1.8.7 (legacy): Couldn't load match `string': No such file or directory

Am I missing something?