subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
+1 vote
510 views 4 comments
by anonymous

I'm using TRB140 and tend to like them. I have around 10 online and number is still growing. They are all behind zerotier, reporting to the server.

Everything worked flawless untill I upgraded them to 07.00. Zerotier looses connection after few hours and never connects again.

Does anyone is experiencing the same issues?

To recap: on 02.06.1 working, after upgrade - not working. Also if I take a brand new TRB out of the box, upgrade to 07 and set up ZT it behaves the same. No difference at all.

Any idea what can be the problem? And more importantly - is there any way to fix it except rolling back to 02.06?


by anonymous
Facing similar issue

2 Answers

0 votes
by anonymous

Port field, in the zerotier settings on TRB140, has to be left empty for it to work on TRB1_R_00.07.00.1 with zerotier package version 1.6.3

by anonymous

but it is empty (80) is grayed out. Yet still there is no access to the device from behind the VPN of ZT.

It is OFC connected in ZT, and shows "online" status.
by anonymous
Were you able to downgrade to previous versions of firmware and zerotier to make it work?

I was able to access the device through zerotier vpn on both older and newer versions of firmware and zerotier, by keeping the port field empty. This has been checked across TRB140, AWS and PC (all on ZT VPN).
by anonymous
Yep. I was able to downgrade. Once done ZT worked like charm again.

On 7 it is not working. If upgraded from previous version ZT is not working. Also if on V7 reseted to default, installed again it is not working.

Tested on TRB, RUTx etc. Same behavior.
0 votes
by anonymous


I've looked into this in a little bit more detail and it seems that this issue seems to be related to a bug that was found in ZT version 1.6.2 and most likely fixed in ZT version 1.6.5 according to this post. More information about this issue can be found on github README page regarding ZT bugfixes and other issues can be found here:

Also, the reason why older FW (02.06.1) does not have this issue is because it's using 1.4.6 ZT version.

The newer ZeroTier package version with a possible bugfix exists only in TRB firmware 7.1 and later but due to IPsec and other issues, the 7.1 firmware has been taken out of the public. If you'd like to try it out with the newer firmware, please message me and I'll provide a download link. However, please note that due to mentioned potential issues with some of the firmware 7.1 services (most notably IPsec), I'd recommend waiting for a hotfix. Unfortunately, right now there is no ETA on it but we're doing our best to re-release the 7.1 firmware with hotfixes as soon as possible.

Best regards,