FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12729 questions

15120 answers

24268 comments

47325 members

0 votes
331 views 2 comments
by
I can't seem to get Nord VPN to work properly on my rutx09. Following instructions on the wiki and also the YouTube video posted by teltonika I'm still have connectivity issues. VPN connects fine but all Internet comnectivy is lost until it is disabled again, I have even reset factory to factory defaults and still the same issue. On firmware v07.00

2 Answers

0 votes
by

Hello,

Once you create the OpenVPN client interface with a NordVPN login, could you please try to navigate to "Network>Firewall>General Settings" (default window) and edit the "openvpn" interface. Once the editing window opens up, find the "Allow forward to destination zones" section, then select it and add "wan" zone to it. Then click on "Save & Apply" to apply the configuration. Let me know if this works for you or if there's still no internet connectivity.

Best regards,

Tomas.

by
Thank you Tomas for getting back to me, I have tried what you have suggested me to do but still not internet connectivity from clients when VPN is connected.VPN connect fine and shows connected but no internet can be accessed from clients, as soon as i disconected or disable vpn all internet is restored.
by

Hello,

In this case there is one more thing that needs to be done but I'll have to ask you to send me a troubleshoot file just to confirm the issue completely. When you connect to the NordVPN service and lose internet connectivity, please generate and send me a troubleshoot file via private message.

What's a troubleshoot file and how to generate it?

A Troubleshoot file contains a device's event logs, configuration files and other info useful for diagnostics. It can be downloaded from your device's WebUI, Troubleshoot page:

System → Administration → Troubleshoot

Best regards,

Tomas.

0 votes
by

The issue has been solved via private message. Troubleshoot file has indicated that the virtual VPN interface was not created when configuring tunnel. This is a known issue and we're aiming to have it fixed in future firmware release 7.2. 

As a workaround, currently it'd be enough to execute the following commands via SSH/CLI on the router and then modify firewall settings slightly. The following commands should be executed in order:

uci set network.vpn1='interface'

uci set network.vpn1.ifname='tun0'

uci set network.vpn1.proto='none'

uci set network.vpn1.metric='100'

uci commit

/etc/init.d/network restart

Once done, navigate to Network>Firewall>General settings (default window), edit the "openvpn" zone and next to the "Covered networks" section select "vpn1". Additionally, make sure "Allow forward to destionation zones" has a "wan" zone specified (screenshot). Then, save & apply settings and try to restart the VPN (turn it off and on) and see if it works after these steps. I'm also attaching a screenshot how the "openvpn" zone should look like when configured this way.

image

Please note that this workaround may not solve these issues if more than one VPN tunnel configured at a time. As an additional way to make sure this issue does not occur often, it's recommended to include the following option in OpenVPN configuration file if possible:

dev tun0

This is only useful when configuring multiple OpenVPN interfaces. Please note that uci commands must be adapted accordingly to this "dev tun0" interface. If only one OpenVPN tunnel exists then it shouldn't be necessary to assign a static virtual interface name for this tunnel.

Best regards,

Tomas.