10417 questions

12418 answers

19280 comments

21748 members

+4 votes
163 views 2 comments
by
Hi,

Today I have installed version 7.01.2 on my RUTX11. A backup is created with the new firmware installed but now a restore fails because of the limited file size (2MB).

Further investigation of the backup-Teltonika-RUTX11.com-2022-01-07.tar.gz shows the following directory sizes in the etc directory.

4    etc/certificates/status
4    etc/chilli
8    etc/certificates
8    etc/crontabs
8    etc/openvpn
8    etc/ppp
8    etc/profile.d
12    etc/dropbear
24    etc/privoxy
60    etc/opkg/keys
64    etc/opkg
104    etc/strongswan.d/charon
124    etc/strongswan.d
296    etc/config
1528    etc/default-config
1888    etc/profiles
4272    etc

The etc/profiles directory is 1.8Mb which is significant when only 2Mb upload is allowed.

Content of etc/profiles

total 1892
drwxr-xr-x  2 cement cement    4096 Jan  7 11:09 .
drwxrwxr-x 15 cement cement    4096 Jan  7 11:25 ..
-rw-r--r--  1 cement cement    4183 Jan  6 20:30 basic_1641409330.md5
-rw-r--r--  1 cement cement  276464 Jan  6 20:30 basic_1641409330.tar.gz
-rw-------  1 cement cement    4344 Jan  7 11:09 default.md5
-rw-------  1 cement cement 1588250 Jan  7 11:09 default.tar.gz
-rw-r--r--  1 cement cement    4183 Jan  6 20:30 template.md5
-rw-r--r--  1 cement cement   36200 Jan  6 20:30 template.tar.gz

I can remove some files from the backup file and upload it but that is not the way to go.

Can you confirm this as a bug and how to solve?

Update:12:00

I have extracted the backup file, removed the profiles basic and default from the etc/profiles directory, created a new backup-file and uploaded to the X11. That worked but it is not the way to go.

1 Answer

0 votes
by
Hello,

Thank you for contacting us.
I would like to know, if you could provide this backup file for a further investigation?
You could attach this file with a comment (attached file will be visible only for engineers) or send via private message.
Thank you in advance.

Best regards,

Sigitas
by

Hi Sigitas,

Thank you for your support and I fully understand that you want to have the backup file for investigation.

But backup files can contain sensitive information like username/passwords for VPN tunnels which are in plain text in the backup file.

For example /etc/openvpn contains auth_xxxxx files with username and password, but also firewall rules can contain sensitive information for certain companies.

Therefore I think you should not ask for backup files.

For now my problem has been 'solved', I have upgraded my router to 7.01.2 and reset it to factory defaults.

From there I started all over again, I don't rely on backup files only but also have documented what to do from scratch and I have reconfigured the system now.

Thanks again for your support.

by
Hello,

Thank you for a reply.
I fully understand your concern, but I can assure, that Teltonika Networks do not use any of backup information and handle all clients given information with high level of confidentiality.
In this certain case, backup file was asked, because I was unable to replicate same issue.
I tried to generate a backup file with a RUTX11, which is used daily and have several VPN configurations, multiple profiles and other custom configuration, but was unable to receive backup file bigger than 400 KB.
I am glad, that at the moment, you was able to solve this issue.
If you will need our assistance again, feel free to contact us.

Best regards,

Sigitas