10513 questions

12523 answers

19448 comments

22055 members

0 votes
146 views 2 comments
by
Hi,

I am using the RUT955 as MQTT broker. I would like to set the Quality of Service (QoS) to 1, so that my publisher nows the data has been received and will be passed on to the subscriber. After enabling the MQTT broker the data is beeing processed but my publisher is not getting an acknowledge. Can someone tell me, how to set the QoS for the RUT955 as broker? I can not find it in the settings of the WebUI.

Thank you in advance

1 Answer

+1 vote
by
Hi, to use QoS on RUT955, you must first install the QoS package. You can install it from the device's WebUI. Or you can download the installation file from the link https://wiki.teltonika-networks.com/view/RUT955_Package_Downloads

You can view the settings in the corresponding section of our Wiki https://wiki.teltonika-networks.com/view/RUT955_Traffic_Shaping#QoS

Best regards.
by
Hi, thank you for the quick reply.The package manager in the WebUI only shows me 16 entries. The QoS and MQTT are not in the list.

Within Services I find QoS so I am expecting it to be installed already. Is that right? In these settings I can not find any way to set a QoS for MQTT though. Is that a different package, or is it possible, that the RUT955 does not support the settings for QoS for MQTT?

Best regards.
by

Hi,

You have not specified which firmware is used on your RUT955. Everything I wrote above concerns only the firmware above 07.00.00. On the 06.XX.XX firmware, QoS is already installed, but there is no difference in the settings there. https://wiki.teltonika-networks.com/view/RUT955_QoS_(legacy_WebUI)

There is no way to assign priority to the MQTT protocol, but you can configure prioritization for the port that is used for MQTT.

Best regards.