subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
702 views 7 comments
by anonymous
Im am trying to disable autonegotiation on the eth0 interface on a TRB140 using ethtool using the command

    `/usr/sbin/ethtool -s eth0 speed 100 duplex full autoneg off`

Most of the time, this command does not work, even `ethtool eth0` gives the following output:

root@TRB140:~# ethtool eth0
Settings for eth0:
Cannot get device settings: No such device
    Supports Wake-on: pg
    Wake-on: p
    Current message level: 0x00007fff (32767)
                   drv probe link timer ifdown ifup rx_err tx_err tx_queued intr tx_done rx_status pktdata hw wol
    Link detected: no

However after trying the command a couple of times, it seems to randomly work.

How can i set persistence on my ethtool commands, if the interface is not detected at boot. I cant use the startup scripts even.
by anonymous
ethtool seems to work after this message in dmesg:

device eth0 left promiscuous mode.

However this only lasts a couple of seconds before the link is back to entering promiscuous mode, and the command can not be run.

1 Answer

0 votes
by anonymous

Could you inform me what is the FW version of this device we're talking about?
by anonymous
Hi, I am running TRB1_R_00.07.00.1
by anonymous

I notice that it is not the latest FW that we have.

Could you update this device to version 7.1.2? it can be downloaded in

Should you still encounter trouble after updating, please inform me again.
by anonymous
I have updated to the specified firmware, and still get the message no such device.

I have found that if i disable the interface, re-enable the interface, and run the ethtool command right after enabling the interface, then i am successful. Waiting longer results in the error mentioned above.
by anonymous
If you are looking to replicate my scenario, i have the following setup:

[TRB140] -------Passive POE Injector -----> ----CAT6 Straight ethernet-----> ----Passive POE splitter--->[Raspberry Pi 4]

Having a passive POE injector means that the link is only capable of 100mbit, however both ends are trying to negotiate 1000mbit.
by anonymous

I cannot replicate your scenario in an exact condition. But I have connect my TRB to an IP camera and found no problem.

Can you confirm that you're able to ping the raspberry device? Please share the troubleshoot file from your TRB, it can be downloaded in system>administration>troubleshoot
by anonymous

The link is down, so it is not possible to ping.The link is trying to negotiate speed.

I hackily fixed it by setting this in my startup script:

# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.
while /usr/sbin/ethtool -s eth0 speed 100 duplex full autoneg off 2>&1 | grep "No such"
sleep 1
exit 0