10490 questions

12505 answers

19431 comments

21988 members

0 votes
268 views 4 comments
by
I just opened my new RUTX11 and it connected to the T-Mobile 4G network just fine and everything was working great, I upgraded to the latest firmware and now I am unable to connect to the network at all.   It keeps giving me a denied error.   I don't know what happened.   I wanted to downgrade the modem to the previous version but it's nowhere to be found.   

Can someone please help me.

2 Answers

0 votes
by

Hello,

This is a known issue with T-mobile operator and our devices and we're working on a hotfix. In the meantime, if you could, please login to the router via CLI (SSH if using third-party tools like PuTTY) and execute the following commands in order:

gsmctl -A at+cgdcont=1 

gsmctl -A at+cgdcont=1,\"ip\"

ubus call gsmd reinit_modems

This should restore the connectivity with T-mobile operator. In order to login to the router via CLI, while in WebUI, navigate to System>CLI and login by entering "root" as the username (without quotation marks) and your router password as the password (password field won't fill in as you write - this is normal, it's hidden intentionally). More information about CLI can be found on our wiki in the following article: https://wiki.teltonika-networks.com/view/RUTX11_CLI

Let me know if this restores mobile connectivity for your device.

Best regards,

Tomas.

0 votes
by
I have a similar problem. I flashed the Firmware RUTX_R_00.07.01.2. Modem FW version is shown as N/A.

After reboot I get a mobile connection for a few seconds. Syslog shows several

daemon.info gsmd[5392]: gsmd[exec_cmd():562]: Modem occupied by FW update...

My mobile provider is Vodafone Germany.

I tried the gsmctl commands above and got: GSMCTL error: reading message
N/A
by

Hello,

This seems like a separate issue, not related to the currently ongoing T-mobile issues. If not already done, could you please connect a WAN cable to the router so that it has internet access via WAN port and then reboot it? It is possible that the router was trying to download and update modem firmware but it keeps failing at some specific step due to no internet access. 

If plugging in the WAN port and providing internet connect via Ethernet is not an option you could try to provide internet access for your router via WiFi (if your device has wireless connectivity). More details regarding how to configure and connect to another wireless network and use it as the main source of the internet, please refer to this article (this option works only for RUT/RUTX devices with WiFi funcionality): https://wiki.teltonika-networks.com/view/RUTX11_Wireless#Client_Mode

If none of these steps solve your issue I'd advise a full factory reset to see if this solves your issue.

Best regards,

Tomas.

by
WAN port was connected all time. So my first FW-upgrade to 7.01.2 was OTA.

What I've done in meantime was reflashing with FW RUTX_R_00.07.01.2. After that mobile connection worked well, maybe due to settings cleared because of downgrade.

After your comment I upgraded again to 7.01.2 with WAN connected. The problem persists even after a full factory reset. The "Modem occupied by FW update..." messages are appearing for over 20 minutes. Mobile connection seems active (traceroute -i wwan0 ... worked). When applying changes to wwan interface (set apn) " Failed to execute AT command: AT+CPIN?" and the "modem occupied..." messages continue. After reboot "modem occupied..." continue every 10s.

Modem status reports "connected", but state and bytes received N/A and SIM not inserted. However mobile data connection seems to work.

Do you have any advice to solve this issue?
by

Could you try to execute this command in CLI:

mctl -r -m modem

This command will reboot the modem which should "unstuck" the modem from its upgrade state. Let me know if there's any progress after this command.
by
I've executed the command. Mobile connection stopped and syslog reports lots of "modem not found" messages.

After that I did a system reboot, but nothing changed: Mobile is working but state is not shown and "Modem occupied..." still fills up syslog.