FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14204 questions

16856 answers

27735 comments

54315 members

0 votes
280 views 2 comments
by
Using legacy FirmWare: 06.08.3

I have windows95 OS and need to connect to Samba USB-Share on a RUT955.

Can not get a connection going.

Did some tests with Wireshark and more modern systems and could confirm that RUT955 uses SMB2

My question:

Can I install SMB1 via SSH on the Linux side of things?

Thank you!

Simon

4 Answers

0 votes
by

Hi,

Yes, you can. Teltonika routers are based on Linux OpenWRT. It uses a Busybox ash shell by default and opkg is currently supported.

Before installing anything, first, enter the command opkg update and then opkg install <package name>

It is also recommended to hard reset the device before doing this, so that it can have empty storage as many as possible.

Best answer
by

Hi Fathull and thank you for this answer!

Unfortunately thgis is not enough information for me to go on :-(

Found and tried this, but I can´t seem to fin any directory /etc/samba/smb.conf using SSH on the RUT955:

https://stackoverflow.com/questions/63372848/how-to-enable-smb1-as-default-and-disable-smb2-and-smb3-on-ubuntu-18-04-server

Can you elaborate / give some more hints?

It is really important for me!

Thank you!

0 votes
by

Ok, I did some research homework and I think I understand your first answer better now.

So you were saying I need to install an opkg-package in order to make the RUT955 learn how to speak SMB1

I have also learned, that the opkg package needs to be compatible in order to work  - which brings me to my next question:

Can you help me find a package?

Or can you tell me where I need to look?

Maybe you have some information about what I need to loo - for example: opkg package compatible with openWRT Version: 12345678

Any help here would be greatly appreciated!

Thanks!

by
Sorry to bother, but I really need help here...

Is there anyone who can support me?

Thank you!
0 votes
by
I found this OPKG for ChaosCalmer 15.05 this is the Version running on my Teltonika RUT955

https://openwrt.org/packages/pkgdata_owrt18_6/samba36-server

Can you confirm this one is what I need?
0 votes
by
...wasn´t easy, but I managed to get this to work!

Thank you for your help!