subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
326 views 0 comments
by anonymous
Hi All.

I have an issue with configuring the DCHP server on an RUT955.

For my particular solution I have configured a OpenVPN VPN in Tap mode (Extending a layer 2 subnet), as part of this, when an IP address is assigned to the VPN adapter from the DHCP server, I want to ensure no gateway gets set (Avoids problems with multiple default gateways in windows OS)

With the older version of FW (R_00.06.08.6), I could add DCHP-Option = 3 and this process would work fine, however with the newer version R_00.07.01.2 a second string field has been added to the webUI, and unless there is a value in this field option 3 on its own won't take (It saves, however when you check, no options are present).

I've tried working around this with nul values in quotation marks, the gateway being set as, and a number of other solutions, all resulting in the DCHP server failing to set any IP...(note: setting a valid gateway via this string works as intended.. Just can't get "No gateway" to work)

I really want to use the "Force DCHP Option" that is available in the newer firmware (as there may be other DCHP servers on the network) so it is preferable to keep the later version rather than rollback.

Does anyone know of a workaround for this problem or can suggest an alternative solution?

Thanks heaps,


2 Answers

0 votes
by anonymous
Hello, Andrew!

Could you please provide a Troubleshoot file in PM?

You could find it in WebUI->System->Administration->Troubleshoot

Best regards, Aliaksandr!
0 votes
by anonymous

You're right, there appears to be a bug in the latest GUI as I just tried the same thing.

The workaround that appears to work is to use the command line interface (or SMS uci commands I guess, with a reboot rather than dnsmasq restart) to get the DHCP option for no gateway in:

uci add_list dhcp.lan.dhcp_option="3"
uci commit
/etc/init.d/dnsmasq restart

Hopefully Teltonika will fix the GUI in a new firmware version so that the DHCP options don't have to have 2 fields.