subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
674 views 9 comments
by anonymous


I bought this modem model. The main reason is to ability to send sms from debian 11 server machine console or script

First of all I tried to check if sms sending is working under windows I tried to use manual sms send But not successfull I'm not expert in gsm networks I tried some commands to understand if modem registered in gsm network All commands history you can see on screenshot I got error My Operator is Latvia Tele2 PIN code asking is removed from sim card

On debian 11 machine modem is detected but minicom cant connect to modem I tried all ttyUSB ports but minicom show offline status It will be next question For linux is smsutils package which allow to send sms via gsm modems connected to usb port

Can somne one assist how to check if modem registered in gsm network and why ot cant send sms?

1 Answer

0 votes
by anonymous


When you try to send an SMS, each AT command must be confirmed by CR+LF, so you need to activate "CR = CR + LF" in the Terminal settings:

TRM modems don't run any firmware. Because of that, there are only a few options that we could suggest.
The first one would be to try to update drivers to the latest version. You can find drivers here:
The second option would try using a different USB cable and see if the issue reoccurs.
If none of the actions would help, then this could mean that issue is related to device hardware.


by anonymous

Thanks I installed drivers for windows from this link All is ok It was clear for me

I'm using usb cable which comes from package

I added missed option to Terminal and get Error But Sim card checked on mobile phone and woks

See latest commands

Thanks for help

by anonymous

Make sure your SIM card doesn't ask for a PIN. And if it's necessary, use AT command +CPIN to enter it:

by anonymous
I dont know I get error for all commands Hm.... I will check sim cards
by anonymous

This is a quick guide to help in the debugging process of a router if encounters issues with mobile data connection:


by anonymous
IT's not router its industrial modem
by anonymous
Yes. it's modem, but the AT commands are the same :)

Review the article above from ATE1 record.
by anonymous

I have next situation I tried to use another cable and another sim card which also I have next situation

by anonymous

I tried to follow with this

And I got in windows Insert sim card

So modem doesnt see sim card But sim card is operable with phone

by anonymous

Note TRM250 supports LTE (Cat-M1) / NB-IoT / EGPRS

Double check does your operator supports Cat-M1 bands. Maybe you may want to use the TRM240 (LTE (Cat1) / 3G / 2G) instead.