10856 questions

12933 answers

20163 comments

25431 members

0 votes
104 views 4 comments
by
Hello,

I'm trying to connect RUT955 using serial RS232 with my energy meter which protocol is IEC 62056-21. I want to make the energy meter online and try to read the meter using its software from other PC using its own wifi. Is it possible?

I have tried using others modem and it works well.

1 Answer

0 votes
by

Hello,

Unfortunately, the IEC 62056-21 protocol by itself is not supported by neither RUT955, nor any other Teltonika device. However, the router can still act as a gateway between the meter and your laptop and can be configured to read data via RS232 and transfer it to the device that supports the protocol, which in this case is your laptop with the energy meter’s software. The data between the router and the remote server would be transferred over TCP/IP which means that you have to choose Over IP mode when configuring RS232. The same result can be achieved using other Teltonika devices as well. These are TRB 142, TRB245 and TRB255.

You can read more on RUT955 RS232 capabilities and configuration options in this website: https://wiki.teltonika-networks.com/view/RUT955_RS232#Over_IP

 Best regards,

Žygimantas

Best answer
by
Thank you sir. I have done the configuration on serial rs232 page. However failed to connect on my PC. I wonder if there is any configuration need to be done on port forwarding or traffic rules. I'm using over IP and server mode and the port same as my PC.
by

Hello,

The first thing to check is whether the RS232 settings (baud rate, number of data, stop bits, etc.) used are correct between the router and the meter. Could you also please specify if the router and the laptop used for data acquisition are within the same local area network or are you using WAN interface to access the device? You can try to test the setup in a local network using some serial monitor (for example Hercules for Windows). In WAN case, you might need to open a port for remote access in router‘s firewall. This can be done by adding a traffic rule in router‘s WebUI: Network -> Firewall -> Traffic Rules. Go to the bottom of the page, set the type to Open ports on router, enter the name of your choosing, select TCP protocol and enter the port number which you intend to use for data transfer. After pressing Add, an additional configuration window will be opened. Make sure it is enabled, source zone is selected as wan, enter source port which matches the configured number in your laptop, save & apply. Check if the correct port is set in the meter‘s software. If nothing helps, please, generate a toubleshoot file and send it to me. Go to the router‘s WebUI, System -> Administration -> Troubleshoot and press Download in Troubleshoot section.

Best regards,

Žygimantas

by

Hello,

I have checked the configuration of rs232 on both sides. everything is right. Currently I am using WAN inerface. I also have open new ports with wan source and destination device, destination address = router IP and destination port = source port. But still failed.

https://community.teltonika-networks.com/?qa=blob&qa_blobid=8510322056993027059

Thanks,

Syafiq

by

Hi Žygimantas,

I have already tackled the issue.  I untick all the box in the serial rs232 configuration and keep the port configuration on traffic rules and I managed to communicate with the meter. Thank you very much for your help.

Best regards,

Syafiq