FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
715 views 6 comments
by anonymous
Hi

By this https://wiki.teltonika-networks.com/view/SMS_sending_command manual all is ok under windows

But under Debian 11, Ubuntu 20,04 lts via minicom I cant send sms Minicom simply cant connect to /dev/ttyUSB2 /dev/ttyUSB3

in lsusb modem is recognized

I can connect to /dev/ttyUSB1 there flows some messages and i cant to do anything

Can some one to help how to get work it under Linux

I need send sms from terminal I need that smssend or other utility see it as /dev/ttyUSBx correctly

Previous post https://community.teltonika-networks.com/44198/teltonika-trm250-cant-send-about-functionality-under-debian

1 Answer

0 votes
by anonymous
Hello,

How much ttyUSB devices appear when you connect your device to PC?

Could it be that you need to install drivers to support this device?
by anonymous
Under windows yes I installed drivers all is ok

under linux there are 4 ports ttyUSB0,1,2,3 I tried all of them via minicom

Also tried another pc with Ubuntu 20.04 lts
by anonymous
What command are you using when calling minicom?

Maybe you bad specified --device or --boudrate because if all 4 ttyUSB devices appear modem should work fine.

Unless some kind of `modem manager` are running in background and thats why there is strange modem behavior because it take modem control
by anonymous
Yes may be. I add same settings as for windows terminal I use basic Debian install without GUI Modem manager not running

Can you help which settings I have to set to minicom I do it by minicom -s command Where in port settings i choose /dev/ttyUSB2 port baud rate 115200, data bits 8, hardware and software data flow are enabled

May be I have press some key to  initialize connection to port Same as connect in windows terminal?

I'm novice in this

Also I tried to run minicom -D /dev/ttyUSBx
by anonymous

minicom screenshot

by anonymous

fixed in debian and now all is ok

apt-get install setserial

  496  setserial -g /dev/ttyUSB[0123]

  497  apt-get install gammu

by anonymous
I think you should disable "Hardware flow control" and then minicom should work fine.