subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
413 views 5 comments
by anonymous
Since the update to RUT2_R_00.07.01.4 on my RUT240 I do not get any more Information about my used mobile data under Status - Mobile Usage - Day (Week or any other)

I already tried factory reset and restore backup of configuration.

But the only info I get is: No mobile data collected!

Realtime data is showed correctly.

Any ideas?

Kind regards

1 Answer

0 votes
by anonymous


Can you please try to do a firmware reflash with the same version (RUT2_R_00.07.01.4) without keeping the settings? You can go to System > Firmware > Update Firmware > Flash New Firmware Image, and disable the Keep settings option.

by anonymous

Hi, thanks,

I tried to go back to RUT2XX_R_00.01.14.5

without keeping the Settings and then go to 07.01.4 also without keeping the settings. Then mobile usage was shown.

As soon as I reloded the backup configuration (which I dont want to loose, as there is a lot of configuration work with various profiles, lots of roules for many different IPs in this config). Mobile usage was lost again. :-(

Is there a possibility to have the configuration reloaded without loosing mobile usage?

Kind Regards

by anonymous


Unfortunately, we don’t have a way to keep all your configuration, since your backup seems to be causing the issue. If you want to save specific configurations, you can go through CLI to the directory for profiles (“cat /etc/config/profiles”), network (“cat /etc/config/network”), dhcp (“cat /etc/config/dhcp”), etc, and copy those lines to a notepad file. Then you can insert those lines on the new config files for the new firmware using the command “vi /etc/config/<filename>”, just replace the <filename> for any of the files you want to copy. To see the use of this command, you can check the following wiki page.

Shell Commands - Teltonika Networks Wiki (

by anonymous

thanks for the help.
I did as proposed and rebuild my configuration after a FW Update without keeping configuration.
I tried it various times without succsess. Then I reset it and built everything by hand again.
Unfortunately it is still not working correctly. It shows the Mobile Data Usage only for "DAY,MONTH,TOTAL" when clicking "WEEK" it still shows: "No mobile usage data collected". Any further ideas?

Kind regards and have a nice weekend
by anonymous


Can you confirm if the service was working correctly before you configured it again (after the FW update)? There might be a conflict between your configuration and this mobile usage status. Also, please share a screenshot of the issue.

by anonymous


yes I can confirm this. But in the mean time, that is why I waited untill today, I see that the problem with the display of "WEEK" is a "sunday-problem"  During the week, all usage data is displayed correctly but on sunday the "WEEK" tab shows the "No mobile usage data collected" Error. This is again so today (sunday). So for the moment it is ok for me, but maybe the "sunday problem" may be fixed on one of the future firmwares.

Maybe nobody noticed it, as most of the people do not work sundays :-)

Thanks for the help, especialy the trick with the CLI an the config files.