11311 questions

13472 answers

21149 comments

31513 members

0 votes
132 views 5 comments
by
Hi,

I am trying to ad an USB-Stick to my RUT955 and use the memory expansion afterwords. I run into the problem, that the USB Stick ist not listed inside the mounted devices.

I tried 3 different usb devices and got always the same result.

Any advice on that issue?

Thanks

Matthias

1 Answer

0 votes
by

Thanks for contacting TELTONIKA | Crowd-support forum.           

The Storage Memory Expansion function provides the possibility to expand the device's flash memory with a USB Mass Storage Device (MSD) and use the extra memory to install additional software packages.

More information can be found here:

https://wiki.teltonika-networks.com/view/RUT955_USB_Tools#Storage_Memory_Expansion

Best regards,

by
Hi Med,

this is not what I am loocking for.

My probleme is, that the storage device is not even regodnized at all. If I plug the USB Storage into the RUT955 I would expect it to be listet under "Mounted file systems", but there is nothing. If I then "Enable storage expansion" nothing is happen...

So I have an issus that the usb storage device is not regodnized at all.

Any Ideas?

Regards Matthias
by

Hello Matthias,

It is recommended that you upgrade the router's Firmware whenever there is a new version.

Try to upgrade the router’s firmware to the latest one without keep setting.

Enter in your router's WebUI, go to System > Firmware:

Uncheck the box of keep all setting.

Select File as Source of the firmware image.

Click to browse your computer for a firmware image file.

Upload the firmware image to the router and attempts to verify its validity.

Click the Upgrade button to begin the update.

 More information can be found here.

Target router FW: RUT9_R_00.07.01.4

Additionally, did you try to use different USB storage device?

Please let me know the result later.

by
Hi Med,

my RUT955 was already running 07.01.4.  and I tested USB2 and USB3 devices with 8GB to 64GB

As you suggested: I made a backup, than reinstalled the firmeware. After that the usb storage got regodnized imidiately. I started the memory expansion and it works fine.

Than I tried to recover my BackUp: the latesed backupfile didn't work, because of the filesize (3.1MB). Why is that? Then I tried an older one (1.9MB) and it worked for all the settings. But now the usb storage device is not listed in "mounted devices". The Memory Expansion is still working and when I do "df -h" inside the console, I can see the usb device mounted.

The Firmeware seems to have some issus left, what makes it really hard to setup the device proporly.

Regards

Matthias
by

Hello,

Storage Memory Expansion works correctly for me under the FW version RUT9_R_00.07.01.4. Pic1Pic2Pic3

First of all, try to reflash your router without keep setting and proceed with Memory Expansion then start with config.

Best regards,

by
Hi Med,

yes thats exactly what I sad. It is working if I  install the firmeware without keeping the setting.

So I will do a complete manually configuration (one more time) and hope that ist will still work when I am finished...

regards

Matthias