FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
759 views 3 comments
by anonymous
Hello and sorry for the easy question, but I still can't figure it out how to do.

I have an rut240 wich has internet via WAN-Port and serving a network 172.16.8.0/24 (dhcp) on LAN-Port
this router is connected to vpn server and gets a bridge IP of 10.10.16.0/20
routes get pushed to the rut240 for connecting the clients on both ends and everything is peachy.

Now I have one device connected to the rut240 LAN-Port with IP 192.168.8.71/24 (static) it buggs me like crazy,
but do to special circumstances I can't change it into the 172.16.8.0/24 network.
It serves data via Modbus-TCP:502.
Up till now I had a workaround with multiple IPs on the service PC to access the machine with the 192.168.8.71/24
but now I have another device to get the data which can't handle multiple IPs.

I tried IP-Alias, VLAN, Firewalls and Routing but could not get it done.

How can I manage to access IPs in another static network 192.168.8.0/24 (static) from 172.16.8.0/24 (dhcp)?
How do I set up the rut240?
Do I set up routes?
VLANs?

Thanks for your help and patience!

1 Answer

+1 vote
by anonymous

Hello,

It's rather unusual that IP alias didn't work for you - it should solve this issue (instead of having to use some other, less conventional methods). Could you run the following commands via CLI (SSH) and see if they work for you? If you're not sure how to login to the router via CLI (SSH), please follow the instructions as described in our wiki page here: https://wiki.teltonika-networks.com/view/RUT240_CLI

uci set network.aliasLAN=interface

uci set network.aliasLAN.ifname='@lan'

uci set network.aliasLAN.proto='static'

uci set network.aliasLAN.ipaddr='192.168.8.1'

uci set network.aliasLAN.netmask='255.255.255.0'

uci commit && reload_config

After running this configuration through the router, it will "know" about this particular subnet. Any device that connects to the RUT240 and has an IP address in subnet 192.168.8.0/24 will be routed via default LAN interface (br-lan) for inter-lan communication or out the default WAN interface for internet connectivity. Let me know if this works for you.

Best regards,

Tomas.

by anonymous

Hello and thank you for the help.

It is not working still, but I kinda figured why it is not.

First: I put an Raspi in the LAN 172.16.8.0/24 (dhcp) and gave it an aditional static IP 192.168.8.25 now, the RPi can ping the 192.168.8.71 and the Router on 192.168.8.1 and 172.16.8.1.
On my windows machine in the 172.16.8.0/24 (dhcp) net I can now ping the RPi on 192.168.8.25 (and on 172.16.8.25 of course)
But still no result with the machine on 192.168.8.71 (static).
The machine itself has an internet connection via LTE in its own network/routes and they use 172.16.0.0/16 on another port. So my ping get's there, but get routet out over LTE. crying

Is there a way not to bridge the networks and make direkt calls, but route them via rut240 and use masquerading for example?

Thanks.

by anonymous

Could you please generate a troubleshoot file from your device and send it over to me via private message? I'd like to take a look at what's going on here exactly. Also - just a note that we generally recommend using latest firmware version (7.01.4 currently) but if you cannot do that for some reason, I'll investigate this issue regardless.

What's a troubleshoot file and how to generate it?

A Troubleshoot file contains the device's event logs, configuration files and other information useful for diagnostics. It can be downloaded from your device's WebUI, Troubleshoot page:

System → Administration → Troubleshoot

by anonymous

Hello again and thank you for your help.

I updated the system to version RUT2_R_00.07.01.4 but this did not resolve the issue.
Cleared last buggy entries in firewall file and could get the zones back.

Clearing the network settings with your code:
uci delete network.lan2.type && uci set network.lan2.ifname='@lan' && uci commit
and initiating a restart, finally did the job.

I can now ping all adresses in both networks trough the router, even without creating firewall settings!

Perfect! yes

Thank you a lot for your help.

Followup question:

A device from 172.16.8.0/24 is scanning the 192.168.8.0/24 network, but can't find a  modbus-tcp device (192.168.8.71). Is there a special protocol necessary wich does not get trough the (bridge)?