10416 questions

12418 answers

19279 comments

21747 members

0 votes
149 views 4 comments
by

when is this going to be fixed?, when "primary" connection is down - internet is down, this is the case in failover and loadbalancing mode - and has been the case for two firmware versions now....

Iam using TWO RUTX12 because o the other issue with modem 2 antenna issues, and still I have same quality as with a $50 china router...

1 Answer

0 votes
by

Hello,

In the screenshot I can see that there are no rules added in the configuration so the service isn't doing anything when main interface goes down. If possible, please login to the router via CLI (using SSH or in the WebUI, at System > CLI) and run the commands provided below to repair the rule configuration. Information regarding logging into the router via CLI is documented on our wiki page here:

https://wiki.teltonika-networks.com/view/RUTX12_CLI

Also, please note that text in bold is new configuration (currently not present in your configuration) - I added the option to flush connections whenever interface connects or disconnects from the internet - this way the failover should look "seamless". You can remove it if it isn't necessary for you or if you find it causing some troubles in your environment.

uci delete mwan3.mwan_Domino

uci add_list mwan3.WAN.flush_conntrack='connected'

uci add_list mwan3.WAN.flush_conntrack='disconnected'

uci add_list mwan3.mob1s1a1.flush_conntrack='connected'

uci add_list mwan3.mob1s1a1.flush_conntrack='disconnected'

uci set mwan3.default_rule=rule

uci set mwan3.default_rule.dest_ip='0.0.0.0/0'

uci set mwan3.default_rule.use_policy='mwan_default'

uci commit && reload_config

Overall, with this configuration, it takes about 30 seconds for the router to switch to mobile interface and for the internet to come back up. If that's too long I'd recommend reducing interval between each ping test or the amount of pings needed for the rule to take effect.

Alternatively, reset the router to default settings and the default failover rule will be present. All that would have to be done at that point is to re-configure mobile and WAN settings and enable the two interfaces for failover functionality.

Let me know if this solves your issue.

Best regards,

Tomas.

Best answer
by

Thanks for reply, i have applied the steps, just checking - is this "normal" - when looking a the created rule?

by

Seems like there's a duplicate member in the policy. Could you login to the router via CLI (SSH) and run this command:

uci show mwan3 

And paste the output here?

by


I have added a couple of rules now because this started working :)
but here is the output.
---------------------------------
Teltonika RUTX series 2022
---------------------------------
root@Teltonika-RUTX12:~# uci show mwan3
mwan3.globals=globals
mwan3.globals.mmx_mask='0x3F00'
mwan3.globals.rtmon_interval='5'
mwan3.globals.mode='balance'
mwan3.WAN=interface
mwan3.WAN.interval='3'
mwan3.WAN.family='ipv4'
mwan3.WAN.enabled='1'
mwan3.WAN.flush_conntrack='connected' 'disconnected'
mwan3.mob1s1a1=interface
mwan3.mob1s1a1.family='ipv4'
mwan3.mob1s1a1.interval='3'
mwan3.mob1s1a1.enabled='1'
mwan3.mob1s1a1.flush_conntrack='connected' 'disconnected'
mwan3.mob2s1a1=interface
mwan3.mob2s1a1.family='ipv4'
mwan3.mob2s1a1.interval='3'
mwan3.mob2s1a1.enabled='0'
mwan3.mwan_default=policy
mwan3.mwan_default.use_member='mob1s1a1_member_mwan' 'mob1s1a1_member_mwan' 'mob2s1a1_member_mwan' 'WAN
_member_mwan'
mwan3.balance_default=policy
mwan3.balance_default.use_member='mob1s1a1_member_balance' 'mob2s1a1_member_balance' 'WAN_member_balanc
e'
mwan3.@condition[0]=condition
mwan3.@condition[0].interface='mob1s1a1'
mwan3.@condition[0].track_method='ping'
mwan3.@condition[0].reliability='1'
mwan3.@condition[0].count='1'
mwan3.@condition[0].timeout='2'
mwan3.@condition[0].down='3'
mwan3.@condition[0].up='3'
mwan3.@condition[0].track_ip='8.8.4.4' '1.1.1.1' '8.8.8.8'
mwan3.mob1s1a1_member_mwan=member
mwan3.mob1s1a1_member_mwan.interface='mob1s1a1'
mwan3.mob1s1a1_member_mwan.metric='2'
mwan3.mob1s1a1_member_balance=member
mwan3.mob1s1a1_member_balance.interface='mob1s1a1'
mwan3.mob1s1a1_member_balance.weight='1'
mwan3.@condition[1]=condition
mwan3.@condition[1].interface='mob2s1a1'
mwan3.@condition[1].track_method='ping'
mwan3.@condition[1].reliability='1'
mwan3.@condition[1].count='1'
mwan3.@condition[1].timeout='2'
mwan3.@condition[1].down='3'
mwan3.@condition[1].up='3'
mwan3.@condition[1].track_ip='1.1.1.1' '8.8.8.8' '8.8.4.4'
mwan3.mob2s1a1_member_mwan=member
mwan3.mob2s1a1_member_mwan.interface='mob2s1a1'
mwan3.mob2s1a1_member_mwan.metric='3'
mwan3.mob2s1a1_member_balance=member
mwan3.mob2s1a1_member_balance.interface='mob2s1a1'
mwan3.mob2s1a1_member_balance.weight='1'
mwan3.@condition[2]=condition
mwan3.@condition[2].count='1'
mwan3.@condition[2].timeout='2'
mwan3.@condition[2].up='3'
mwan3.@condition[2].track_method='ping'
mwan3.@condition[2].reliability='1'
mwan3.@condition[2].down='3'
mwan3.@condition[2].interface='WAN'
mwan3.@condition[2].track_ip='8.8.8.8' '8.8.4.4' '1.1.1.1'
mwan3.WAN_member_mwan=member
mwan3.WAN_member_mwan.interface='WAN'
mwan3.WAN_member_mwan.metric='1'
mwan3.WAN_member_balance=member
mwan3.WAN_member_balance.interface='WAN'
mwan3.WAN_member_balance.weight='1'
mwan3.domino=rule
mwan3.domino.proto='tcp'
mwan3.domino.dest_port='1352'
mwan3.domino.use_policy='mwan_default'
mwan3.WHM=rule
mwan3.WHM.proto='tcp'
mwan3.WHM.dest_port='2083-2087'
mwan3.WHM.use_policy='mwan_default'
mwan3.default_rule=rule
mwan3.default_rule.dest_ip='0.0.0.0/0'
mwan3.default_rule.use_policy='balance_default'