FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
685 views 7 comments
by anonymous

Hello,
while playing with RUT950 settings I've found this issue: cannot switch off VPN tunnel by SMS command. According log file it seems the closing sequence starts, but opens tunnel again immediatelly. So VPN tunnel keeps connected. Log file attached.
What is wrong? FW RUT9_R_00.07.01.4

1 Answer

0 votes
by anonymous

Hi,

It seems the SMS device authorization are reminds by default: Admin password that I've seen the password was missed and SMS format was sent incorrectly, you need to put open real client or server name without prefix client or server. .

You should send out the SMS in the following format:

admin password vpnoff maco

Please change admin password to your device real admin password and send out the SMS to test again.

Regards,

Ledong

by anonymous

Not sure I undestand.
Currently the authorization metod for default SMS utilities vpnon/vpnoff is set to no authorization. So I use simply rule inside SMS (no password).
Regarding VPN name: the GUI always adds prefix "client" to VPN tunnel defined. So my tunnel name is client_maco.
So the name client_maco is valid for SMS command according manual, isn't it?

by anonymous

Hi,

You can find your log indicating mismatched password per log attached:

Fri Apr  1 09:13:24 2022 daemon.info unhandler[3340]: libgsm[src/libgsm_auth.c:253]: Password: Vpnoff not match

You may need to reboot device to apply the "no authorization" changes.

The webUI added prefix "client" or "server" to indicate the type of tunnel, it actually did not change the tunnel name, in your case, remains in maco.

You can test to send out SMS vpnoff maco after no authorization setting has been successfully applied.

Regards,

Ledong

by anonymous

Hi,
right, after reboot its a bit better, because after SMS command vpnoff maco it switches VPN tunnel off. But:
1) after reboot I've also tried to send SMS vpnoff client_maco. It was accepted by router, because a disconnecting routine was started at 11:32:25 - see attached log2.txt (in VPN server log I see that client disconnected and connected again). Why? Unmatching SMS command must be ignored.

2) then I’ve tried to send SMS vpnoff maco (in log at 11:35:06). After it VPN tunnel closed properly. The specification of SMS commands for manage VPN is confusing in manual, especially when GUI adds client_/server_ prefix to tunnel’s name defined by user. Would be useful to specify it better in manual to in order to prevent such a misunderstandings.

3) is it necessary to reboot router after change of it’s configuration in order to work properly? It is very important to know it because of reliability!

by anonymous

Hi,

Please find my responses in Blue

1) after reboot I've also tried to send SMS vpnoff client_maco. It was accepted by router, because a disconnecting routine was started at 11:32:25 - see attached log2.txt (in VPN server log I see that client disconnected and connected again). Why? Unmatching SMS command must be ignored.

System was accepting vpnoff command to turn off VPN tunnel but could not prevent the VPN being reconnected due to mismatched VPN name 

2) then I’ve tried to send SMS vpnoff maco (in log at 11:35:06). After it VPN tunnel closed properly. The specification of SMS commands for manage VPN is confusing in manual, especially when GUI adds client_/server_ prefix to tunnel’s name defined by user. Would be useful to specify it better in manual to in order to prevent such a misunderstandings.

Thanks for your recommendation. We will look to update the manual accordingly to avoid the misunderstanding.

3) is it necessary to reboot router after change of it’s configuration in order to work properly? It is very important to know it because of reliability!

Reboot is recommended after configurations have been changed in order to apply the settings correctly.

Regards,

Ledong

by anonymous

After few months I'm preparing the new RUT955 and found that SMS command "vpnoff client_maco" does not work. It seems the working syntax is now "vpnoff maco" (without prefix "client_"). Was this behaviour changed in last FW release (RUT9_R_00.07.02.1)? 

I'm totaly confused now, according informations provided in SMS command notes in WebUI, WIKI and forum! Can you please explain it?

by anonymous

Hi,

There was no changed in RUT9_R_00.07.02.1. The command and syntax remind the same as we discussed:

vpnoff client_name

vpnoff server_name

client_name and server_name should be replaced by your own Openvpn client or server's name. In your case, it's maco. Thus, the SMS command to turn off VPN should be: vpnoff maco

Regards,

Ledong

by anonymous

right, probably I confused myself. Need to remeber that right command is simply vpnoff maco although WebUI shows that tunel's name is client_maco. Thank you