FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
373 views 6 comments
by anonymous

Hi!
Trying to set up an L2TP client on RUT950. The L2TP server require pre-shared key.
There is no field for that, only Server, Username and Password.
Running the RUT950 with firmware RUT9_R_00.07.01.4
Any advise?


1 Answer

0 votes
by anonymous

Hello,

L2TP Client’s configuration only requires those parameters (server, username, password). You have the option of L2TPv3 as well, which requires different parameters. You can see them on the following wikipage:

RUT950 VPN - Teltonika Networks Wiki (teltonika-networks.com)

If you configure a L2TP over IPsec, that would require a pre-shared key to configure the IPsec instance. You can see a configuration example on the following link:

L2TP over IPsec - Teltonika Networks Wiki (teltonika-networks.com)

by anonymous

Unifi USG is running L2TPServer with Pre-shared key. Tested the second example above and L2TP is not able to login, IPSEC is up.

How it looks on the Unifi USG.

by anonymous

Hello,

Does the IPsec configuration also require Pre Shared Key? Please share a screenshot of this.

Also, verify the connectivity from the RUT950 to the server. They should be able to connect with ping.

If this works fine, do some tests again trying to connect to L2TP after IPsec is up, and download the troubleshoot file (System > Administration > Troubleshoot > Troubleshoot File). Please, share this file on the first post so we can check the logs.

by anonymous
I manage to get it going after alot of trial'n'error.

One thing that does not work that is to force all traffic running trough the tunnel.
The "Default route"-option in L2TP does nothing. On or off, no change.

Also tested to add an manual default route 0.0.0.0 to the L2TP but no success.
by anonymous

Hello,

I’m glad you made it work. If you are having trouble with the default route, please share the troubleshoot file following the instructions given before and screenshots of the pings or telnets going the wrong direction.

by anonymous
Had to go back to V6 firmware on the RUT950. V7 was way to unstable, wifi goes down now and then, the same with LTE.
Perhaps the default route-failure on L2TP is also an V7-bug.

V6 is more stable and I shall redo the L2TP Client-setup as soon as possible.
by anonymous

I have re-done everything in latest V6 firmware and I can confirm that the "Default route"-option in L2TP is working in V6 and NOT in V7.