subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
967 views 0 comments
by anonymous

I have a RUT955 (RUT9_R_00.07.01.4) and set NMEA a forward to my Rasberry Pi which runs Victron's Venus OS Large. I put in its ip adres, TCP and port 10110 (tried also 8500).

This Venus OS has a Signal K server running which lets me add data connections. I tried both NMEA2000 and NMEA0183 and the al give the message "connection refused" (Apr 06 08:11:21 TcpProvider:connect ECONNREFUSED

Is there anybody who has GPS data forwarded to Venus OS (Large)?

1 Answer

0 votes
by anonymous


RUT955's GPS NMEA functionality simply sends RAW NMEA information to specified server. It does not have any authentication.

Below you will find brief example instructions how NMEA data could be sent to TCP server on computer. Screenshots in example are made on slightly older WebUI design, but nonetheless whole idea still remains the same with current latest firmware version.

Instructions (4rth page is not relevant for you in this situation):

Exactly the same approach can be done on your Rasberry Pi: you would simply need to launch simple TCP server to capture the data. Afterwards you would be able to use any other software to parse NMEA data.

For testing purposes you could start everything from sending data to Hercules TCP server application, running on computer.

Best answer