subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
423 views 4 comments
by anonymous

Hi All:

I have been upgrading configs our our 300+ RUT950 units that are in the field. I've been pushing the RUT9XX_R_00.06.08.6_WEBUI.bin file up to the routers for FW updates and this is working great.

After the update finishes I do the following:

1. opkg update

2. opkg install openssh-sftp-server

Works a treat except for one router. It updated fine, rebooted and when I run "opkg update" it just sits there and does nothing:

root@CORS214:~# opkg update


I can exit this with cntrl-C and can successfully ping
root@CORS214:~# ping -c 2
PING ( 56 data bytes
64 bytes from seq=0 ttl=48 time=156.292 ms
64 bytes from seq=1 ttl=48 time=160.766 ms
--- ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 156.292/158.529/160.766 ms
So I have name lookup. How do I troubleshoot this?
Why will it not update?

2 Answers

0 votes
by anonymous
Guessing last option is to pick it up, factory reset - and try again. Since reboot does not help.

If you open second terminal and watch process with top, and space left on device.. does it tell you anything ?
by anonymous
Top doesn't show anything interesting.

But two days later, CORS214 updated fine. What's up with that? I updated other units the same day fine but this particular one needed a two day rest?

I have another unit today doing the same thing. I will try it tomorrow to check it.


by anonymous
Compare one box to another, watch the processes that run on the machine.. are they identical ? Are they places on different locations, one struggling with connection while the other is placed near a cell site.. Do they connect to same kind og provider ? is the db signal low on one device and high on another device ? there should be some differences... compare and see is my vote ;)
by anonymous
This site is on Fiber.

its not using GPRS.

I tried today just reinstalling the FW using the file-upload technique, was done successfully.

opkg update still fails.

I have updated 4 other routers this morning and they are worked.


0 votes
by anonymous


I'd advise trying to reflash firmware on the faulty device using the Bootloader menu. It should clean up any (potentially) faulty configuration which may have been left over from older firmware versions. The Bootloader menu is the router's special state that can be achieved before the Bootloader loads up the router's OS. For more information about this procedure and how to access the Bootloader menu, please refer to this page on our wiki:

To download the firmware version manually, please refer to this wiki page:

Additional note - in case you decide to flash router with FW version RUT9_R_00.07.01.4, but it fails (error in the Bootloader menu), please try reflashing firmware version on device using legacy FW version RUT9XX_R_00.06.08.6.

Best regards,

Tomas P.

by anonymous
After 4 days had passed, opkg update worked.

I don't know why.