10909 questions

13001 answers

20269 comments

26790 members

0 votes
200 views 3 comments
by

Hello

I received my brand new X11 last week, plugged it in connected over LAN 192.168.1.1, router wizard started and showed a Firmware update to 7.01.04.

I didn't note it, so not sure if it was on a 2.0 or 7.0 when I applied this upgrade??

I applied this and went about configuring the device for dual SIM connection only (NO WAN, NO WiFi) this device is in a rural area and only had Cellular connection available.

After inserting the SIMS and powering up I got connected to one provider but and hour later connection dropped and never came back, this also happened on the 2nd provider, even after calling their tech support and setting the APN to a custom value as provided them.

Only way I was ever able to get this X11 to work was factory rest and re-flashing it with RUTX_R_00.02.06.1 

Connections have been stable and working since this downgrade.

Question is there some bug that doesn't like the settings to be inputted in version 7.01.04? 

Internal modem firmware version: EG06ALAR02A07M4

Kernel version: 4.14.19

Now that it is working I am very nervous to upgrade back to latest version as this device will be located in a remote area and up a 30' pole.

Any help would be awesome.

1 Answer

0 votes
by

Hello,

Thank you for your question.

Try to upgrade your firmware to the newest version which you can find here: https://wiki.teltonika-networks.com/view/RUTX11_Firmware_Downloads 

And don't keep the settings from the old firmware. If you kept setting from the old firmware most likely your router will not function properly. After a successful upgrade, configure everything that you will need.

If after a clean system upgrade you will still lose internet connection then provide this information to us

Kind regards,

Edvinas

by
Sorry I need more help, can you explain, the process to do the best upgrade, I have read that use boot-loader?

I see when I'm on WebUI under System Firmware a newer version 7.01.4, and I did this upgrade before and had issues, I don't want the latest version maybe the previous on 7.01.2

Can you provide full recommended firmware upgrade procedure. Unit is now installed 2 hours away up a 20' pole inside an enclosure, any way to do a proper upgrade remotely or on-site without have to physically take down the X11?
by

The bootloader menu is a special router state used as a recovery tool in case the router becomes inaccessible even after a factory reset. It can be used to update the router's firmware or bootloader version.

Bootloader usually is not used for upgrading firmware, it's mostly used for recovering the device. Here you can read more about the Bootloader.

I would highly advise you to have a router near you before upgrading firmware, just in case something goes wrong.

Here is the list of options on how you can update your RUTX11 firmware:

1. Download the latest FW from this link: https://wiki.teltonika-networks.com/view/RUTX11_Firmware_Downloads. In your router navigate to WebUI, navigate to System > Firmware > Flash new firmware image, press the button Browse and select your downloaded FW. Proceed with FW installation and wait ~3-5mins for the router to fully update(in this time router will be unreachable).

2. By sending the SMS command "fw_upgrade admin_password" to your router's SIM card. It will activate the FW update from the server after this command was executed your router will reboot and start the FW update (in this time router will be unreachable).

3. Upgrading FW by RMS. Download the latest FW from this link: https://wiki.teltonika-networks.com/view/RUTX11_Firmware_Downloads. In RMS navigate to Management > Devices, select your RUTX11, and select Actions > Update Firmware. Upload your downloaded FW and start the FW update (in this time router will be unreachable).

4. Via CLI. Here you can find tutorial: https://wiki.teltonika-networks.com/view/Firmware_upgrade_via_command_line

Let me know if you need further help.

Kind regards,

Edvinas

ago by
I have working T-mobile data lines that crash after upgrading to latest firmware.  Immediately after upgrade to latest, starts roaming on AT&T network with unusable slow speed.  This has happened on multiple X11 routers over the past several months.  What can be done to resolve other than never upgrading to latest firmware when connecting to T-Mobile?  What is the latest firmware that has been tested with T-mobile with static IP address (b2b.static)?