10416 questions

12417 answers

19277 comments

21740 members

+1 vote
124 views 5 comments
by
Hello

My RUT955 serial 1107155247 Batch: 087 had a problem after updating to firmware version 7. It downloaded the new version from the server and installed successfully. However, after the upgrade it only showed the login page and a blank page upon user/pwd inserted.

I followed downgrade instructions from bootload and installed factory firmware 6.08.6 in http://192.168.1.1/index.html. It worked well, started to work well again. However, it is unable to upgrade firmware from the WebUI interface when checking with the server. When I try to install the latest 7.01.4 firmware  from bootload, it shows an error.

Is this unit unable to upgrade from now on?

Thank you,

Daniel
by
Hello,

The same WebUI freeze is happening here on my RUT955 Batch 087 after a hard reset attempt which didn't involve any bootloader/firmware upgrade. I can still do SSH login, also I noticed that the hostname changed to Teltonika-UNKNOW

This all happened on the latest RUT9 firmware, which was working fine before the reset button was held down.

After that, I loaded again the very bad legacy firmware, and loaded again the RUT9 firmware, but the situation didn't change. I'm still locked out from the WebUI.

Would you please:

1) Update the bootloader so that it would accept as valid the checksum of the latest RUT9 firmware

2) Provide a way to fix my device?

Thank you

1 Answer

0 votes
by

Hello,

Based on the device data related to your serial number, you should be able to update to the latest firmware. However, regarding update from the bootloader, the latest firmware you can install is 6.08.6. 

I would like you to try to download the firmware file from this link and upload it to the router's WebUI. Before updating, disable keep settings option.

Best regards,

Žygimantas  

by
I have identical situation. Over-the-air upgrade (from Teltonika firmware server) to FW 7.01.4 causes Web GUI to become unusable due to JS script syntax error in login components. I tried using Bootloader (192.168.1.1/index.html) to "downgrade" firmware to RUT9XX_R_00.06.08.6_WEBUI.bin but after 5 minutes the "UPDATE IN PROGRESS" never completes but all of the lights (apart from power) turn off. I waited 2 hours,  tried again, but same results. This leaves me with a "bricked" router that fails to boot and refuses to "bootload" the official factory firmware. My serial number: SN 1120382215.

Anyone have any suggestions?

Thanks,

Virgil
by
Hello,

In case of bootloader procedure failure, you should return the device or ask for a replacement.

Best regards,

Žygimantas
by

Hi Žygimantas

Thank you for the help.  I downloaded the firmware file from your link and uploaded it to the router's WebUI, disabling 'keep settings option'. Unfortunately the result is the same as before, the router shows me the new login interface and freezes after entering admin/admin01 credentials. Screen below.

Interestingly the system refuses wrong passwords. But doesn't work anymore with the correct credentials. Is there anything else we could try?

Best,

Daniel 

by

Hi @Žygimantas - thanks for advice to "return the device or ask for a replacement". I did return the device, and in the meantime I purchased another RUT955 from a different vendor....which produces EXACTLY THE SAME PROBLEM!!! Here I will document the problem.
(Although I am unable to login via the web browser, I was abel to login via SSH and issue command 
mnf_info -sn, which returns the serial number  RUT955003XXX 1117993499)

How to produce the problem:

  • Upgrade RUT955 to RUT9_R_00.07.01.4
  • Clear browser cache to and tap F12 in browser to open "dev tools"; have the Console tab in view, then attempt to navigate to 192.168.1.1
  • Note the Teltonika WebGUI will not load due to JavaScript errors:
    • Error 1: FireFox browser Syntax error: expected expression, got ")" in file chunk-vendors.583b0542.js, row 80, column 14490. 
    • Error 2: Chrome browser Invalid regular expression, missing "/" in file chunk-vendors.583b0542.js, row 118, column 808.
    • Error 3: FireFox browser Syntax error: missing ":" after property id in file app.a50901dc.js, row 1, column 297750.
    • Error 4: Chrome browser Unexpected token "&" in file app.a50901dc.js, row 1, column 141034.
    • Error 5: Opera browser Deprecated use of User-Agent string in file chunk-vendors.583b0542.js, row 1
      • Note: if this error is ignored then the WebGUI does appear to load and function
  • Note: OS Microsoft Windows 11 Pro, build 22000.652. Chrome browser version 101.0.4951.54. Firefox browser version 99.0.1. Opera browser version 86.0.4363.50.
Workaround:
  • Upgrade to the latest Microsoft Edge browser and ONLY use that browser to access the Teltonika RUT955 on firmware 07.01.4
Can you, as a representative of Teltonika, confirm that the firmware RUT955 to RUT9_R_00.07.01.4 is not suitable for use with the Chrome and Firefox browsers listed above?
 
Thanks,
Virgil